Implementation of Aqua Temp controlle

@davidtja I opened the WiFi module (4 screws in each corner under the sticker) and removed the internal antenna replacing it with an external antenna which I had lying around from an old WiFi router which was about to go to e-waste.

Side note the HiTemp App has been very unreliable the past few weeks, several times yesterday (and today) I wasn’t able to connect to the cloud via either the App or from HA.

1 Like

Hi, I’m having the same issue.
The aqua temp app is working fine, and I can control the heatpump through that.
But I can’t log into the Aqu temp account through the HA integration - when I put the correct credentials, it says I was successful, but doesn’t show any devices connected. In fact it will let me put any username and password in and still say it was successful.

Is the ssl certificate mentioned in DagoB above still an issue?

Any suggestions?

I’m keen to get this integration working !

Thanks in advance

Think there are issues with the hosts.

It is now fixed for me with v3.0.13

Hi All,

I read this thread when trying to talk directly to my heatpump/aquatemp and it helped me enormously. Although I am not an HA user, I thought my journey through a NodeRed implementation may help you all.…L3Krl7_H51Z1tFqnpi417Iw0vtOvZ7oqZBjtkIbFl/pub



@qwackers How did it work out with your antenna modification? I too am hawing issues with it frequently going offline despite having fairly good wifi at the location of the dongle. Would you recommend doing as you did?

If the question is still relevant yes absolutely I recommend - my WiFi reliabilty went from <5% to 100% so I recommend it.

I have a Norsup P20TX/32 Norsup heatpump and it has a PC1004 PCB too.
In this thread I see you posting modbus registers so I was wondering if you’re actually controlling the heat pump through modbus? If so, I will try on my heat pump soon too…

When I asked the manufacturer (norsup) about the protocol, somewhere in 2021, they replied to me saying that it’s a proprietary modbus protocol and they won’t share any data. But maybe that was just a lie ?..

Hi, im trying to make an api request for an other arduion application but cant get it to work. Not familiar with HA, but seems like it should work anyway. Tried with postman etc without success. Maybe someone can support me?

has anyone worked out what the username and password is for the HiTemp wifi module is for its HTTP port?

I think admin admin works but I just get an error 404 after that.

Are you having issues with the HiTemp app at the moment? It’s not working for me stopped working about 10 am yesterday.

there were lots of 502 errors over the last week, contacted support of app and told them that the app is working very slow (didn’t lie) and most likely the restarted their servers.

as for hitemp, login is working but the problem is with the device codes that are not aligned, i need to have some available time to investigate diagnostic file and logs i received from one of the users.

Yes… I’ve experinced some issue both in app as well as HACS “GitHub - radical-squared/aquatemp: Home Assistant AquaTemp Heat Pump Climate Entity” plugin.

Eventually the app issue self-resolved. For HA, delete the entry and re-add resolved the issue once the app issue is resolved.

When the server went down, my heater didn’t turn back on according to schedule. During troubleshooting, I reseted wifi module and made not difference, however its interesting to note after schedule is set on the water heat itself, the schedule on the hitemp app shows the schedule is off. This suggest to me that the scheduling works one way(on the control unit itself) or the other (cloud base scheduling).

I thought the error 404 means wrong username and password was entered too many times. reset the wifi unit seems to get it to prompt for username and password again.
I’ve been trying to work out a way to include heating mode into scheduling. but its currently not possible in hitemp app. and the climate entity in HA is not working for me.

Never trusted the app scheduling myself. I have a basic schedule on the device to prevent it from using peak power between 3 pm and 9 pm. If the on-device schedule had been imported into the app when I connected the wifi module I would have been confident with it.

I have an EVO heat 270 HWS and the HA integration is pretty much useless to me, I can’t control it at all. The only thing I get is water temp telemetry sorta handy. This request has been sitting around for a while which might make it more usable. Support Water Heater Entity · Issue #54 · radical-squared/aquatemp · GitHub

I have the same heater model. EVOheat support was quick to sell me the module, but the support has been useless both at the distributor and the head office.

Yeah, I guess most people just leave it set up the way it was installed and forget about it, The whole purpose for me to go Heatpump was to drive efficiency despite the fact my gas storage had a small hole at the time of changeover. I had to have control so bought the module and have found it useful just wished the HA integration was better.

Would it be possible to use tasmota to avoid problems with their servers?
There is a NeoPool tasmota project that can read all the data through an RS485 converter and I don’t use the official app anymore.

Yeah, I wish for a better solution. I have flashed many Sonoff devices with Tasmota and it is brilliant firmware. The connection from the EVO heat HWS to the HiTemp wifi module is RS485 but I don’t think it running Modbus. I did attempt to sniff the RS485 at one stage. Could see data but nothing resembling Modbus.