Impossible to install on Lenovo Tiny?!

I’ve had zero luck going with the Generic x86-64 on a Lenovo Tiny M92. I use the ubuntu live approach and balenaetcher to copy image over to the HDD. All goes well, proper partitions seem to be made on the Tiny, but as soon as I reboot, there’s the “Error 1962 No Operating System Found”! Tried a whole bunch of BIOS combination settings (compatibility mode etc) nothing seems to work. Has anyone had better luck with these devices?

It took me ages to install a non windows OS on this thing.

It is working fine now on debian 11 with supervised. I had to update the BIOS. Youtube showed me how.

EDIT sorry mine is a m72e not a m92, but it sounds like the same problem, and probably the same solution.

Does the Tiny M92 support UEFI ? HA OS requires UEFI.

Yeah that is what the bios update was necessary for, to get UEFI boot support. I think this was the video BIOS Update on Lenovo ThinkCenter E72 3493-KAG - YouTube . Having wiped windows, I had to create a usb boot device like in the vid.

Yes, it does support UEFI, and yes, I did the BIOS update to the latest. I can surely install Debian 11 and go supervised, just annoyed the HAOS thing is not working out…

Did anyone get this working?
I was previously running debian 10 and supervised install, but saw generic was available, so wiped the machine and 3 days later still pulling my teeth out.
I miss my home assistant :joy:
Using an RF remote to open the garage door, feeling like a pleb lol

As above my m72 is fine running debian 11 and supervised.