Home Assistant Community

Incorrect Reported Time / Dark Sky

#1

Hi All,

I’m seeing something strange with the Darksky sensor and an IOS device. If I use my laptop (WIn 10) and look at the forecast from Dark Sky, I have no problems. But, if I use the IOS App, or use the firefox web-browser to access Home Assistant, the time reported for the forecast in Dark Sky is incorrect. The image attached shows (in red) what my IOS device reports for time, I took the screenshot from my Win 10 machine and marked it up.

Did I configure something wrong somewhere?

2018-10-07_23h35_27

#2

time zone settings on iPhone or computer are not set correctly most likely

#3

edit: Add my iphone timezone setting

I went into the container and did a cat /etc/timezone => Etc/UTC. So i changed the container and added a binding to /etc/timezone & /etc/localtime. Still reports the wrong times to my ios device.

My Windows PC is in EDT <- this one still has the correct times reported
My Ubuntu server (hosting the container) is in EDT
My iphone timezone = Detroit
& now my home-assistant container is in EDT (after adding the above binding)

configuration.yaml:
time_zone: America/Detroit

#4

what time settings do you have on your iPhone?

#5

Sorry, forgot to include that bit of information. I edited my previous post for clarity.

#6

Hmm. Do you have the Timezone set in configuration yaml?

homeassistant:
  name: Home
  latitude: !secret my_latitude
  longitude: !secret my_longitude
  elevation: !secret my_elevation
  unit_system: metric
  time_zone: !secret my_timezone

Really the only reason for the behaviour you describe is a time zone mismatch somewhere. HA always works in UTC and uses the time_zone above to adjust.

Oh crap… I see you have that set…
Out of ideas here. Sorry.

#7

I have this problem as well. Any solutions?

#8

I have the same problem as well. I’m on Hassio 0.80.3 but have noticed it for a while now on previous versions.

#9

Just noticed my times are wrong differently on pc vs iphone. Neither is correct but are different.

#10

I have verified my timezone settings on the server running docker, the docker image running Home Assistant, and my ios device timezone.

I think there is an issue between ios and Haasio with timezones.

I also recently updated to the latest release and still have the issue.

#11

I would like to report the same issue. I’m running Hassbian, have the correct timezone set in the configuration file (and verified, as log entries are correct), but dark sky is showing UTC values.

#12

yup. same here, interestingly the logbook that is also iOS timezone based shows the correct timeszone… some issue with the card I think.

#13

Same here, running Hassio and have the time zone set in config but getting the wrong time in Dark Sky forecast. :frowning:

#14

I have the same problem. I tried various combinations of timezone settings on the OS, docker container and ha configuration without success.
I am wondering if it is an issue with the dark sky component.

#15

I had the same issue from PC until installing the new Chrony add-on

Prematurely posted as on the iPhone the time is still incorrect which is mystifying
let me know on your end