Increase GPU RAM in Pi4 with HassOS SSD Boot setup

Hi all,
I have searched quite extensively on the community and found several posts on the subject, but unfortunately could not succeed in my seemingly simple GPU memory adjustment. On the regular Pi it’s a small change in the config.txt, but I just can’t figure out how to set the GPU RAM on HassOS booting from my SSD. Anyone willing to share the way in baby steps to me?

What I tried so far:

  1. Installing ‘Advanced SSH & Web Terminal’ aka ‘SSH 22222’ but I can’t find a config.txt or even the boot partition :blush:
  2. Pulled the disk and connected it to
    1. Windows (since I expected the boot to be FAT), but no luck
    2. Linux (Debian), but again wasn’t able to identify the partition to mount, nor found a config.txt file

For those who care/are interested in the reason.
I want to give Frigate a go without it killing my CPU, which it does now if I enable it. Since Frigate needs at least 128, where the Pi defaults to 64, to use the GPU, I need to increase it. Planning to increase to 512, read somewhere that was the limit to keep a reliable system. Since it’s a 8GB Pi, I don’t expect to experience any memory shortage doing so.

Hope anyone has an idea how to achieve my goal. I am running Core 2024.1.5, Supervisor 2023.12.1 and Operating System 11.4.

A one time bump, hoping someone can help me out.

The easiest way is if you boot HAOS from a SD card and use the data disk feature. You then can easily edit the config.txt file which is on the boot partition (first FAT partition) of your SD card on your PC. HAOS uses a squashfs read-only file system, and all data, including the complete Home Assistant Core installation, Add-ons etc. are running from the SSD directly. So you’ll have all the speed benefit of the SSD still.

If you want to access the boot partition through the running HAOS, it is only available on the OS level SSH access on port 22222, which isn’t meant for debugging use. This guide shows how to enable it. The config.txt file is located at /mnt/boot. However, with that method, if you do make an error in the configuration which prevents booting, you’ll have to recover using method 1 :cold_face:

Thanks, I’ll have a look at the SSH approach soon, hopefully tomorrow.

It took a bit longer, but today I had time and succeeded in login on to SSH 22222
Thank you very much for pointing me in the right direction.

1 Like

I am also trying out Frigate on my 8GB RPi4. Did you succeed in changing the GPU memory? How were you able to verify that it had in fact changed? If it worked; how did it impact Frigate? Thanks!

I was able to change it but was never 100% sure about Frigate actually using it. I tried multiple memory sizes (within the specified range). You should at least be able to tell based on the Pi CPU load while it’s detecting.

My Frigate System page also shows rpi-v4l2m2m but it writes:

There was an error getting usage stats. This does not mean hardware acceleration is not working. Either your GPU does not support this or Frigate does not have proper access to get statistics. This is expected for the Home Assistant addon.

I ended up buying a Coral USB Accelerator and am happy with the systems load and improved detection speed of about 14ms.

I also have a Coral on the way. Did you see a drop in CPU usage with the Coral? As far as I understand both video decoding (ffmpeg) and detectors use CPU. My main problem is the high CPU usage on decoding. I have turned detect off and video decoding still uses over 60 % of my CPU capacity. I am curious if the Coral will help with that situation.

I with Home Assistant had more insight into the RPi hardware. So see firmware versions, GPU memory etc would be very useful.


Yes, CPU loads are acceptable now. You of course need to address your Corel hardware in the detectors section. See the documentation for that.

Further more, I use a separate 720p 5fps stream for the detection. If your camera support that, I’d advise you to do so.