influxDB Grafana and HA

Hello my fellow home assistants,

I have the following setup which is working quite well and stable.

AEON Zwave 5
2531 Zigbee

and that about covers it.

I starting this thread because most of the InfluxDB Grafana basic setup threads are a bit outdated and as I have tried to install InfluxDB several times without success I was wondering if there is anyone with more experience or in depth knowledge to help out.

I watched several video’s on the subject and done exactly as discribed but when I use FF to and look in Influxdb the homeassistant Database doesn’t show.

Some help here would greatly be appreciated.

Did you watch this one?

1 Like

Hi @tom_l amd thank you for contributing to this thread. much appreciated :wink:

yep I did,

It goes a bit fast and I have the setup the way it’s explained. I have also watched a video from smart home junkie whom is also quite a good HA instructor.

The Issue is that when I open Influxdb after restarting the the database called homeassistant is not shown. At least not on in FF. When I look at it on an Ipad th database is shown but none of the sensors binary or otherswise are shown.

Yeah but there are not only pause and rewind buttons on youtube but playback speed controls as well.

Not shown where?

In the addons dashboard?

hahaha that is an awesome answer LOL

nope in the explorer. on the Mac in FF no database visible even though in configuration it says connected. On my Ipad I can see the database but there is nothing to select and measure. so it seems no data is being transmitted.

In the InfluxDb explorer?

Have you added the yaml to your config to tell HA what to send, something like this:

  host: a0d7b954-influxdb
  port: 8086
  database: homeassistant
  username: homeassistant
  password: !secret influxdb_pssword
  max_retries: 3
  default_measurement: state

That will send everything.

I use includes to only send the entities I want long term data for:

  host: a0d7b954-influxdb
  port: 8086
  database: homeassistant
  username: homeassistant
  password: !secret influxdb_pssword
  max_retries: 3
  default_measurement: state
      - binary_sensor.dark_outside
      - binary_sensor.master_bed_occupied
      - binary_sensor.night_vision_active
      - binary_sensor.spare_bed_occupied
      - binary_sensor.pir_bathroom
      - binary_sensor.pir_deck_front
      - binary_sensor.pir_deck_side
      - binary_sensor.pir_dining

yes yes, thats all in the config.yaml and carefully QC-ed for typos and what not.

are there any issues with FF and mac that you know of that might hinder the database being displayed?

Nope. It’s also my browser of choice and is working perfectly.

Though I am using FF on windows.

So indeed that is the screen that I see but I don’t see the homeassistant DB on the Mac and with FF

On iOS Ipad as in Safari I do see the database but no domain, entity etc etc so nothing to select.

I realize though that it’s quite hard to help without seeing anything on my end.

After a look around I did find the though in my homeassistant log:

“021-04-28 15:01:41 ERROR (SyncWorker_3) [homeassistant.components.influxdb] Cannot connect to InfluxDB due to ‘HTTPSConnectionPool(host=‘a0d7b954-influxdb’, port=8086): Max retries exceeded with url: /write?db=homeassistant (Caused by SSLError(SSLError(1, ‘[SSL: WRONG_VERSION_NUMBER] wrong version number (_ssl.c:1125)’)))’. Please check that the provided connection details (host, port, etc.) are correct and that your InfluxDB server is running and accessible. Retrying in 60 seconds.”

So I forget exactly which of these two causes that error but sounds like you have one of the following two configuration issues:

  1. You set ssl to true in the InfuxDB addon configuration but did not add ssl: true to the influxdb configuration in HA
  2. Vice versa (you don’t have ssl enabled in the InfluxDB add-on but have ssl: true in the influxdb configuration in HA)

If not either of those things then maybe a certificate error? If using a self-signed certificate you either have to provide the CA using the ssl_ca_cert option or add verify_ssl: false. I thought that error had a different message though.

EDIT: Also if none of those suggestions fixes it please share your config. Since it sounds like HA did find Influx at the address provided and simply can’t write to it. So that means there is a problem with the configuration of one of the two preventing HA from making API calls to it.

1 Like

Hi Mike,

thanks for your reaction. do you mean the config.yaml?

Yes. Somewhere in the configuration.yaml for HA or one of the files it includes you must have a section for influxdb which looks kind of like what tom showed above. What does that section of yaml look like?

Hi Mike,
Sorry for my late reply. It was late last night and with time diff I didn’t have time to reply.

  host: a0d7b954-influxdb
  port: 8086
  database: homeassistant
  ssl: true
  verify_ssl: false 
  max_retries: 3
  default_measurement: state

I have put verify_ssl to false based on what you mentioned earlier.To no avail.

How do I ad an ssl cert in to influx?

You would need to make one. If your InfluxDB service is only accessible from within your network then you’d need to make a self-signed certificate using openssl. If you’ve made it publicly accessible then you can use Let’s Encrypt or something. I wouldn’t really recommend exposing it publicly unless you have to though, like if you have things outside your LAN that need to send it data.

If it is only exposed within your local network then you might also want to consider simply turning SSL off. It’s not required to use SSL here, you can set ssl: false in both the add-on configuration and that configuration. Most people do that to be honest.

Also in case you’re wondering, you can set ssl: false in the InfluxDB add-on even if you access HA using SSL. The SSL option in the InfluxDB add-on only controls how other things like HA access its API. The UI you always get to from within HA using Ingress and the ssl option has no impact on that.

Hi Mike,

Once again thanks for your suggestions. I have fiddled around with this a bit, but for now I am noticing that I’m not getting anywhere. Most likely because of my lack of knowledge and the time it takes to figure things out.

I’ll try to pick this up again at a later stage.


I had the same error, and all config seemed correct. Couldn’t get any details from the logs that gave me any clue. When I then reinstalled I just happened to see something about “listening on port 8088”. No error or anything. Then I remembered that another addon was using that port. So I changed that port and all other ports in the range of 808X since both 8086 and 8089 also are being used by the InfluxDB addon. In my case it was my MotionEye addon that was using these ports for streaming access to the cameras. So have a look at your other addons to see if any are using these ports.

Good luck!

1 Like

Hi Erik Thanks for your reply.
I did have a look but at the time I tried I did not have any camera’s running. NOt in motioneye and not in any other add-on .

I am running HA through duckdns in order to also connect through the companion app and as such I should probably install and configure the Nginx server. But I’m bit scared of messing up my HA instance when doing that :wink: