Initial Login Failing

I am installing Home Assistant on Docker following the instructions located at : down near the bottom under the Debian separate supervised Install on a docker setup. I have set it up this way twice before and it worked flawlessly. The first time I messed things up trying to set up a domain NOT on DuckDNS and it would no longer start. So I decided to start over. The second time every thing was working great until I tried to add in the Nortek HUSBZB-1 combination Z-wave Zigbee USB device. After doing so I could not get Home Assistant to start after a reboot. So I decided to do another clean install - no big deal since I am really trying to learn how things work, and each time I learn new things.

But I have tried three times to get Home Assistant up and running and it keeps failing. I tried with the HUSBZB-1 plugged in the first time and it got to the Preparing Home Assistant with the could take about 20 minutes screen and froze. It would not complete. I removed just Home Assistant from Docker, removed the HUSBZB-1 and reinstalled Home Assistant - same result. So I did a clean reinstall of Raspbian with Etcher on the SD card. I installed Samba and I set up domain access from the Pi to my Windows Domain following the process located at I then made sure all was working, joined my domain and made a backup of the SD card. I then followed the steps identified above and installed Home Assistant using Docker. This time it completed and the Preparing process completed and it came up to the Create Account screen. I went thru the onboarding steps, created an account located Home and set the item zone and elevation. I did a power off and made another backup copy of the SD card. I plugged the card back into the Pi and now it will not connect. It gives me the same error as the previous times :

This site can’t be reached refused to connect.

I can see the entire card from Windows since I have Samba up and running. All of the appropriate .yaml files are there. Everything is in place as it should be. I can also log into the Pi using PuTTY and everything works fine there as well. I can run HA CORE INFO and see the expected info there. One thing I have noticed is there is a file in the directory \usr\share\hassio named multicast.json. I do not recall seeing such a file previously. I did add an aircast app to my Smart TV and to my Smart phone just before all these problems started occurring. Could this be the issue? If not why does this install keep failing to connect? Might it be related to joining my domain?? That is also something I just got set up and running right before all of these issues started. I am stumped. Any help will be greatly appreciated.