Inofficial Zigbee Router firmware released for ITead Sonoff ZBBridge and ZB-GW03 Zigbee gateways/bridges as alternative when used with Tasmota and/or ESPHome

FYI, xsp1989 has uploaded a signed Zigbee Router firmware for ITead Sonoff ZBBridge which could possibly make it a Tasmota/ESPHome connected Zigbee Router (instead of as a Zigbee Coordinator):

This is the signed routing firmware used by ZBB, the usage method is the same as the unsigned firmware.

You think Tasmota/ESPHome can send basic commands to it to initiate paring/joining and restart/reset?

Update! FYI, the same Zigbee Router firmware image has now also been tested on ZB-GW03 eWeLink Ethernet Zigbee Gateway (sold under many brand names, including EACHEN and SmartWise brands).

Idea around this is also discussed for ITead’s Sonoff ZBBridge hacked with Tasmota/ESPHome here:

PS: Have not tried this myself as I got rid of my ITead Sonoff ZBBridge because being WiFi-based it did not work any good as a remote Zigbee Coordinator, but might reconsider buying one if it worked as a Zigbee Router device that can be paired/joined and restarted/reset remotely via Tasmota and/or ESPHome. So that Tasmota/ESPHome is basically only used to initiate virtual join/pair button and restart/reset the device similar to a remote power-cycle it hangs.

Update from xsp1989 on router firmware posted on

"This firmware can ground the PA00 5S into pairing mode, and ground the RST to restart routing. UART is used to transmit data transparently.


“There is also another version of the routing firmware that can control the join network through a proprietary serial port protocol”

Checkout new “How to Convert the Sonoff Zigbee Bridge into a Router / Repeater” article by @digiblur

Note that the article already assumes that you have flashed Tasmota onto ITead Sonoff ZBBridge, see:

When using Zigbee2MQTT it requires that add an external converter for zigbee-herdsman-converters:

It will then show up in Zigbee2MQTT as a model “UT-01” and manufacturer “easyiot”:

zigbeeModel: [‘UT-01’],
model: ‘EFR32MG21’,
vendor: ‘Custom devices (DiY)’,
description: ‘EFR32MG21 Zigbee Bridge Router’,

@digiblur has updated his article about how to convert ITead Sonoff ZBBridge into a Zigbee Router:

Without new quirk in ZHA Device Handlers it will show up as “easyiot UT-01” in ZHA integration:

Hi! Finding some troubles when I try to pair the router to my coordinator z-bee pen ( CC2652P chip based 3.0 adapter). ZHA doesn’t find the device…

FYI, the same Zigbee Router firmware has now also been tested with ESPHome on a ZB-GW03 eWeLink Ethernet Zigbee Gateway which is based on ESP32 instead but have the same “SM-011 V1.0” EFR32MG21 Zigbee module by CoolKit that ITead uses in their Sonoff ZBBridge Zigbee Bridge:

ZB-GW03 eWeLink Ethernet Zigbee Gateway ZB-GW03 v1.0 / V1.2 is based on ESP32 and have RJ-45 Ethernet port, it is also sold rebranded under many names, including EACHEN and SmartWise brands:

ESPHome can be installed on both the ESP32 based ZB-GW03 and the ESP8266/ESP8285 based ZBBridge Zigbee Bridge:

If using Tasmota on it then suggest post to →

If using ESPHome then post to → [REQUEST] Zigbee Router configuration for ESPHome on ZB-GW03 · Issue #12 · syssi/esphome-zb-gw03 · GitHub

Tip! @digiblur has updated his blog article again with alternative methods to put into pairing/join-mode:

You should today of course also make sure that you are using tasmota-zbbridge release 11.0.0 or later:

Hope someone can help, I replaced my ZB-GW03 by a Sonoff ZB usb stick (Plus/E?). Used the radio migration function all works like a charm. So far so good.

Now tried to repurpose the ZB GW03 as a router. the ZHA network however can’t find it, presumable because the IEEE address of the new bridge and the previous bridge/now router are the same? Provided this is indeed the correct assumption, any thought on how to change the router IEEE address?

Hi. Did you ever manage to change the IEEE address of the old one?
I’ve used migrate radio from a sonoff tasmota zbbridge and can’t find a way to change the sonoffs address

Unfortunately not. The router is idle for 4 months

OK, got it working! There is probably a much easier way using ZHATools or a cluster command but this is how I did it.

Download a backup of the zigbee network settings
Modify the IEEE in the backup json - at the bottom under node_info
Configure the sonoff on another instance of HA
Restore the modded backup on the other instance ‘permanently’ overwriting the IEEE

then just follow the instructions for making it a router and add to the original instance.

Not difficult but a bit of a faff. Like I say, there is probably a much easier way than this. Maybe do it on the same instance as long as all is backed up? I wasn’t in the mood to get it wrong and have to set up 40 devices again - and then possibly have HomeKit to deal with too.

So far it’s working. Should probably restart and make sure.
I’ve noticed that it is added in as a router with the new IEEE address and i can see LQI RSSI values. However, it doesnt have any children or neighbours… on the visualisation its not connected to anything. I’m not sure what’s going on

OK - all working as expected… I checked it again after applying some HA updates; I think it was the restarts/ time elapsed, rather than the updates.

1 Like

any instructions for the zigbee pro?

there’s no option 75 so I just get a Upload Failed Invalid file signature error

1 Like

You have to change the template in configuration > configure other > Template form field

Thanks, it worked for me as well!

Sorry to raise this from the dead but I am having issue adding the old sonoff zbbridge to the newly migrated radio as a repeater. I followed the article posted here. But when I go to zha and add device, it just doesn’t show up to be paired. Can someone please point me in the right direction? Thanks

Has anyone found an easier way to change the IEEE? Setting up another instance of home assistant seems an awful lot of work.