Inovelli 2-Channel ZWave Outlet/Receptacle

I don’t know this is so much a project as a review but it did not seem to fit anywhere else.

I have a receptacle behind my sofa in the living room and it is the only one on that particular wall. On each end of the sofa, we have a set of lights (Pole style with three LED lights on each, each controlled by its own twist type switch). My practice has been to leave one of the lights on before going to bed to prevent general calamities if getting up in the middle of the night and partly for security purposes.

I wanted to control this more through automation rather than having to remember to turn the light on, you know, make it all geeky and such, not that I’m too lazy to turn the light on. At any rate, being there is only one receptacle on that wall the typical GE ZWave receptacle was not going to work unless I used an extension cord or something like that to tie both lamps into the one ZWave receptacle. I was not really too keen on that idea. What I ultimately wanted to do was to rewire the lamps so that each had two plugs on it. One would go to a dedicated light for the purposes of being plugged into a ZWave receptacle while the other would go into another full-time powered receptacle. In such way I would have one light on automation, the others we could use as needed whenever we needed.

I was not about to rewire my lamps, though, until I had some solution in place in which doing so would set things up as I had envisioned. Just before Christmas, I ran across what I thought might be the solution to my delima. I found a 2-Channel ZWave receptacle. I was skeptical but they were not terribly expensive and I thought I would get my hands on one after Christmas and see how it all goes.

I finally ordered one and it arrived. So I thought I would share my experience thus far. First, let’s look at some pics of the device:

I have never heard of the brand before, so I only ordered one for testing

The next step was to pair the device with my Aeotec Z-Stick. I wanted to do this manually so I would know what to expect out of the pairing process so I did not use the HA frontend to do so. I grabbed my Z-Stick out of the RPi and then plugged the device into a receptacle and made sure it was on.

The instructions say to ‘toggle’ (the button on the front of the device) 3 - 5 times within 3 seconds. My first thought was, surely they are joking and just making sure the device sends out its command. Nope! They are dead serious. I tried just turning it on and off, no pair. I tried turning it on, off, and back on, no pair. Finally, I did as they instructed and just kept toggling the on/off button fast until the Z-Stick indicated it had paired.

I put the Z-Stick back into the RPi and then shut down HA and started OZWCP. Once the discovery/updating process was done, the switch was there in the list of nodes:

No configuration items to change. What most will probably notice is that it actually shows three switches. They are not differentiated in any way. One of the switches controls the device itself being on and off (in this case, the middle switch). The other two are for the separate receptacles.

This seems to be a relatively new device on the market (as far as I am aware anyway) and hopefully, they will change this in the future so that the switches are distinctive. It also confuses things because when you group switches in HA it will provide a master ON/OFF toggle and essentially, that is what the ‘third’ switch does here. It is essentially a group turn on/off identical in how HA provides a group turn on/off. I will show this later.

I was concerned, initially, that the device shows up in OZWCP as an unknown device and unknown type, but I decided to roll with it and see how things turn out. I shut down OZWCP and restarted HA. Once up and running I checked the entities list.

I thought, okay, maybe HA recognized the devices own group switch for what it is and left it out of the entities list. That was not the case as you will see soon. So I set up the entities so they would show up under my home tab, then restarted HA and got my nice group card.

After HA had fully loaded and settled it was time to give it a whirl and see how things work. Please excuse the pics, my bike was the only thing in the vicinity I had to clamp my test lights too.

I turn on the first, Channel 1 switch:

NOTE: I have no idea if it is channel 1 or 2 that is just how I labeled them. I assumed the entity id of 67_0_2 was indicating that 2 was the first outlet and then 3 would be the second.

Then I turn on the second, Channel 2 switch:

It works!!

However, that third switch was kind of bugging me and why it did not show up intitially in the entities list, so I went back to check the list again, and this time it was there.

So I set it up to show up in my group card and restarted HA:

Here, you can see it is clearly performing the same function as HA’s group turn on and off or at least seems to. If I turn off that switch, the HA group switch turns off as well:

If I turn on just one of the channels, the HA group switch turns on, but the device group switch does not:

So I am not really sure what purpose of the device switch is. I initially thought that if it were off, then you could not turn on any of the channels, but that does not seem to be the case. So it is a bit confusing, but it seems safe to leave it out unless you need it for some automation purpose.

Some closing thoughts

It is a nice device for the most part, not terribly expensive ($35 shipped) but it has some limitations. Namely, in the amount of power it can handle. The Aeotec Smart Switch 6 can handle up to 15 Amp which is pretty standard for a residential receptacle. The Inovelli can only handle up to 10 Amps and that seems to be divided across the two channels, so 5 Amps each:

I suppose it is a trade-off for getting two channels with one device, and quite frankly, I can live with that. Every light in my house is LED including all outdoor lights so the lights on the ends of my sofa are not going to pull that much power. In fact, I have another such light in another room connected to an Aeotec Smart Switch 6 and it pulls only about 0.75 Amps with all three LED lights on. I am only wanting to power one per channel with this switch.

When plugged in, the device does not block the other top outlet which is nice. I think, like all Z-Wave devices, it has its place. If you do not need to power something with a large current draw, this could be the device to use. Now, I suppose it is a matter of durability. Will it handle the daily use it will see over the long haul. Time will tell.

I hope this has helped someone and if it’s too much just say so and I will refrain from doing so in the future, my thinking was that someone might benefit from the information and may not be aware that such a device exists.

1 Like

I thought this was a great review, too bad it seems to be unavailable/out of stock everywhere I look for it.

BTW, @fabaff - maybe it would be a good idea to start a reviews section in the forums for things like this. I think if people were to write up reviews of this caliber, it could be really helpful.

Thank you, sir. That was part of the problem for me. I saw it and wanted to try it but had trouble finding it. I eventually found one on eBay and went from there.

I would add that I would love to do more reviews like this, even for things that are commonly used because I like to include the information on the pairing and configuration process. It takes a while to do, but I enjoy it.


I’ve always wondered why they have the always on outlet on these. Instead just give us a small switch on the back or something that either makes it always on, or zwave controlled. Especially if it’s leaving the second outlet free like these do. I agree on the idea of doing reviews though. I am playing with several different items now and would be happy to contribute.

I just picked one of these up (16amp version) and added it to Home Assistant through the built in Z-wave panel rather than through the Open-Z-Wave panel. It ended up giving me 5 switches rather than the 3 you got.

The fist two do the same thing, toggle receptacle 1. The third toggles receptacle 2, the fourth and fifth toggle the third switch instance (not the receptacle directly) and then turn themselves off after a couple seconds.

None of them toggle both outlets at once like yours.

Any idea what’s causing this behavior?

You must have a newer version and a beefier one as mine is a 10 amp. I won’t be of any assistance to you, unfortunately. It may be that whatever the extra switches are, are unsupported in HA too. Though that would kind of seem odd as its a switch, but possible I suppose.

Unfortunately, HomeAssistant can’t seem to decide whether this device has one switch, two switches, FOUR switches (yes, four), or none at all. It keeps showing entries like this, where it decides that the “old entity id” is wrong, and updates it with a “new entity id” that removes the sub-device specification

old entity id
new entity id
value instance
value index
value id
node id

Unfortunately, I have been having this issue too and I am not sure which upgrade it started with. Yet another breaking change I suppose is what it will be the reason. It’s been working perfectly all this time and all of a sudden, upgrade HA and everything gets changed.

I love HA, don’t get me wrong, but I truly, truly hope that by the time they get to 1.0 that have a better workflow in place for some kind of user beta testing before they release an upgrade.