Inovelli Switch - How Do I Toggle 2 lights on button press with ramp up/down

Tags: #<Tag:0x00007f325592a840> #<Tag:0x00007f325592a750> #<Tag:0x00007f325592a688> #<Tag:0x00007f325592a5c0>

Hi all! Apologies for the simple (I hope) question. I have been searching around and can’t find a good answer.

I have an Inovelli Red Fan / Light switch that controls a fan with 2 Tuya Smart bulbs in the fan light fixture. I have the Inovelli switch set up such that the power to the smart lights is always on (local protection) and I have an automation that triggers when someone taps the light button on the switch.

What I am having a problem with though, is getting the 2 lights to come on simultaneously, and ramp on, not just instant on. What is happening is that the first light in the action section turns on/off first, followed by the 2nd light in the action section a few hundred ms later. They also just flash on and don’t ramp up or down.

How do I make the lights turn on simultaneously (or as close to that as possible), and ramp up/down?

My current configuration:

alias: Livingroom - Fan Light Switch - Single Press
description: ''
trigger:
  - platform: event
    event_type: zwave.scene_activated
    event_data:
      entity_id: zwave.switch_living_room_fan
      node_id: 5
      scene_data: 7680
      scene_id: 2
condition: []
action:
  - type: toggle
    device_id: d33261aaee22853c1444a457a613c7ee
    entity_id: light.ebb46858ac2f261801anvk
    domain: light
  - type: toggle
    device_id: 7cab3c8fbfb2029058568c4519d051b7
    entity_id: light.eb5679f37ffba8a945o7ap
    domain: light
mode: single

I have also tried activating scenes, which I think worked a bit better in terms of simultaneously activating the lights (still not great though), but I wasn’t able to make it ramp there either.

Edit – So I figured out that the lights that I am trying to fade, don’t support that feature. Now just to get them on at the same time.