Input Number Display mode as Input Field

Not 100% certain if this belongs in this category, but here is my issue, which is rather weird:

I am managing 4 instances of homeassistant across several homes for my family

To make the fine-tuning of certain behaviors a bit easier for the rest of the family, I mostly use input numbers in my automations so that I can expose only that part to them on the interface.

In 3 out of 4 of the installations (HassOS) I get the option to switch the display mode for an Input number from Slider to Input Field when I try to create a new input helper, or when I go into the settings menu of the relevant input number.

However, on the 4. instance, this option isn’t shown, no matter what I try. All of them run on the same hardware and are on the same version of HA, and the issue has been persisting across multiple updates, so I’m pretty sure this is a matter of configuration in some hidden menu. Does anyone have an idea where this setting could be buried?