Input Select with no initial value

Is there a way to have an input_select start with no initial value?

When Home Assistant starts I don’t want the input_select to have any state. I tried initial: '' but that flags an error.

The only work around I can think of is to have an option that would not normally be used, something like “Choose” or “Select.” My only complaint with that route is it shows up in the drop down.
Screenshot 2022-02-25 094725

Try using
' '

I’ve tried initial: '' and your suggestion of initial: ' ' but both throw an error.

Invalid config for [input_select]: initial state is not part of the options: Choose,Both,Left,Right,Bottle for dictionary value @ data['input_select']['feeding']. Got OrderedDict([('name', 'Feeding Options'), ('options', ['Choose', 'Both', 'Left', 'Right', 'Bottle']), ('initial', ' ')]). (See /config/configuration.yaml, line 496).

You ahve to add it to the options too

1 Like

Ah, thank you for clarifying! That does seemed to have worked. There is still a blank space now as an option which I like much better. I’m guessing there is no way to get rid of the blank space since it is now an option?

Screenshot 2022-02-25 094725

Correct. Otherwise you’ll have to modify the card itself or use a custom card. I’m not sure if one exists

Understood. Thanks for your help and quick responses petro!