Install 2 copies of hassio on same network

Is this possible.

Wanted to set up the new hassos on a second pi3b and get it working before I switched from my main setup.

Tried lots of fresh setup all with the same result. I see the installing wait 20mins screen then after an hour or so the page is not accessable tried rebooting with no difference.

I have tried
32bit version 1.7 hassos
64bit version 1.7 hassos
32bit version 1.9 hassos
1.1 resinos (this is the version running on my main setup)

Swapping the working SD card between Pi’s and both work fine.

I have seen other posts with similar issues installing hassos but I don’t even seem to be able to use resinos.

Any ideas

Plug it into a monitor and look for any relevant messages.

Also, is it on your lan?

Ordered a cable today to connect a display. So will let you know on this one.

Yes it is connected to LAN not WIFI and the lights
on the connector are as I would expect.

I’ve got two on the same network. Just make sure they are running on different ports

What? Why different ports, that makes no sense at all.

Dunno why. I couldn’t open the web UI, changed the port in the config rebooted and it worked.

Just pause and think about it.

1 Like

I had the same issue as him and I’m just saying what got it working

Edit if both are running at the same time I should say

I also can’t think why this is a problem but I never say never.

Did you have to set one up change its port and then add the second or is there a way I can access the config without access to the UI (so not set up SSH or samba)

Is it because you were trying to use “hassio.local” which resolves to both instances?

You absolutely, 100%, do not need to use a different port for 2 different physical systems.

I just installed a second instance of HA on the same machine using docker and it works perfectly.

I had to use different ports in that case.

I previously had HA installed on two different machines for a couple months and it worked then too.

Cable arrived

When I first plugged it in it was displaying the home assistant logo but was still not accessable.

Decided to reflash the SD card did this and it went through a lot of text after about 10 mins the text scrolling slowed down and some errors shown.

Installing hassos 1.9

It’s still going after about 3 hours

Any ideas

Seem to have solved the issue with a 3rd SD card. It seems reliable as well as I have now reinstall several time due to my next issue with restoring my snapshot.