Install Aeotec Zstick on VM

Hello,

I have suceesfully installed Homeassistant on a VM and now I’m trying to utilize my Zstick. The system don’t seem to recognize the stick.
The path /dev/ttyAMC0 is not right.
ls /dev/tty* reports:
/dev/ttyS0
/dev/ttyS1
/dev/ttyS2
/dev/ttyS3

Tried all the above and initially the stick seemed to be included but when I tried to start the ZWave network nothing happens.

I would be grateful if someone could help out with this.

Are you running the software collection formerly known as HASS.IO?
There’s a nice hardware tab on the Supervisor section that might be helpful if so, it should show some weird glob of text connected as a device if you’ve passed it through to your VM properly. I’ve disconnected mine recently so I don’t remember what it reported as.

1 Like

Hi Keith

Thank you so much for your input!
The hardware tab reports serial:

/dev/ttyS3
/dev/ttyS0
/dev/ttyS2
/dev/ttyS1

I tried all these.They are being accepted as successful but when I try to ‘‘start’’ the ZWAVE network the cycle spins forever with no result…

I’m wondering if there’s a way to force a choice of mine as a serial port?

Are you sure the stick is passed from the host to the VM? What hypervisor are you using? VMWare Workstation? VirtualBox?

1 Like

No, I’m not sure by any means so feel free to correct me whenever you think I might be missing something. Completely new to virtual machine thing. :stuck_out_tongue:

I’m running it on Virtualbox.

Thanks again!

To answer my own question, I found this guide:

I haven’t done anything like that to let the VM see the actual usb devices connected to the host computer.

I will try these setting and will report back.

1 Like

Sorry, night got crazy last night. Not in a fun way. I only have experience with VMware products, so I hope it worked out for you!

1 Like

I use virtualbox on windows 10, running hassos in a Vm, and I pass through my z wave stick so it IS possible.

1 Like

Thanks somuch for your help guys.

I managed to get it working by following the video above. In fact I had not had passed the USB devices to my VM machine.

Another problem I’m trying to resolve now is to get the Samba extension to work.
Seems a bit complicated the whole thing as the extension itself has to be configured with the VM network settings and not with the actual host adapter’s.
Any ideas? Do I have to bridge the actual host adapter with the VM’s under Windows network settings?

Mine is set to bridged.