Install app on android car multimedia

Hello.
I am using the app in my phone and it works great.
What I want to do is to use it also in my car. I have a Chinese no-name android multimedia system and at the moment I use chrome to log in through duckdns. I would prefer to use the app since it could give the location of the car directly to HA and not by installing other app (like Life360).
When I try to set it up, if I am at home and is connected to home WiFi, it doesn’t find HA so I need to put it manually.
When I do (exactly the same way I did it to my android phone), it is stuck forever at “initalizing”…
I tried it both in home WiFi and by using 4g data.

Is there anything that I could do?

Thx!

does your device have google play services? Does it also have android system webview? these are things that are required for the app.

I had Google play services and through Google play I installed Android system webview.
Again the issue remains the same.
Staying forever at “initializing”.

Anyone have another suggestion?

if your device did not have android system webview pre-installed then you’ll want to root it and run xposed as there is a plugin that makes it a system app.

https://repo.xposed.info/module/net.typeblog.webview

I had to do this on one of my custom ROM devices and it worked. Hope that helps

Unfortunately it is a no name unit and I have no idea how to root it. :confused:
Thank you though for your reply.