Install error -- What can I do?


What can I do? Where is the error?


INFO Reading configuration /config/esphome/esp32-bluetooth-proxy-c75968.yaml...
INFO Generating C++ source...
INFO Compiling app...
Processing esp32-bluetooth-proxy-c75968 (board: esp32dev; framework: espidf; platform: platformio/espressif32 @ 3.5.0)
Tool Manager: Installing platformio/toolchain-esp32ulp @ ~1.22851.0
INFO Installing platformio/toolchain-esp32ulp @ ~1.22851.0
Error: Could not find the package with 'platformio/toolchain-esp32ulp @ ~1.22851.0' requirements for your system 'linux_aarch64


Thanks a lot, greetings

Some libraries aren’t available for aarch64, try running esphome on your pc.


thank you very much for the answer to my question.
Strange thing is, I have about 1 week ago with the
ESP32, have flashed him via HomeAssistant. There were no problems…
I find that strange.
I have the ESP32 via ESPHome Bluetooth Proxy
again, new integrated in HA. I can view the log via WLAN. But if I change something on the
configuration and then reflash it comes this error.

Many greetings

If all else fails. My ESPHome install became confused. And I got compile missing library entry errors. After configuration backup I deleted ESPHome AND the folders and reinstalled

I will try that again. I had
already installed a backup which was about 3 weeks old,
but that didn’t help either. I have not deleted the ESPHome folders.
I will do that once now.


Had the same problem. Check the github page for the solution. Install ESPHome Beta, as suggested by @balloob fixed it for me.


I have already tried with the beta version and it worked then.
Only unfortunately the configuration of the Text_Sensor does not work.
This is my configuration:

  name: esp32-bluetooth-proxy-c75968
  esphome.bluetooth-proxy: github://esphome/bluetooth-proxies/esp32-generic.yaml@main
  name: ${name}
  name_add_mac_suffix: false

  username: xxxxx
  password: xxxxx

  ssid: !secret wifi_ssid
  password: !secret wifi_password

 - platform: ble_scanner
   name: "BLE Devices Scanner 

    interval: 1100ms
    window: 1100ms
    active: true

Maybe someone has a tip for me.

I have now installed the version 2022.12.0b5.
It works now also the text sensor and I can use the
BLE devices in the environment.
It may be that it also works with the previous versions.
with the previous versions.
I have now found out that the ESP32 has to be manually re
must be restarted manually. So it does not start automatically after an update.
In any case, with the version 2022.12.0b3 there were still
a “red” error message when updating the ESP32. This does not happen anymore. But there are many “yellow” lines !

Many thanks to the developers and greetings…

Translated with DeepL Translate: The world's most accurate translator (free version)