Install on Raspberry Pi4 on SSD

Hi guys,

as I’m worried about the SD-card crash issue, I just bought a P4 (2GB), a USB SATA controller (for Raspberry) and a SSD.

Unforuntately it’s not working out of the box.
I flashed on the SSD and plugged the sata controller via micro usb to the USB port of the raspberry.

After plugging in the power adapter nothing happens.
I don’t own a micro HDMI cable so I can’t see what’s the problem.

Do I need to configure anything to boot up directly from the SSD?


USB boot is not currently available for the raspberry pi 4 (see Raspberry website).

Regarding, if you tried HassOS, note that USB boot is not currently available (may be in beta in a few days or weeks)

Sorry but you have to wait

Damn, then I should have bought a 3+ ?

Ok then I will run my old Pi 3 until they will enable USB boot for the PI 4

Thanks for the info/reply @makai

Here you can see if the USB-boot is available. At the time of me writing this message it isn’t.

1 Like

I saw that a beta version of the pi4 ssd boot thing is available. I was trying to follow this guide as I understand hassio is very limited in what functionality that is available, so I guess that this method doesn’t work.

Nice find, I think I may wait until it’s out of beta before going for this on my Raspbian based setup :slight_smile:

1 Like

I found a link to a fairly simple proceedure to set it up to first boot from the SD card and then switch to the SSD drive.

Hi Fred
What image did you flash/move to the SSD?
Andreas Spiess has several videos on youtube about different methods of moving installations from a SD to a SSD, but the standard image I used to flash does not use buster, so I can’t make them work.
Also I have a very limited knowledge about linux so I like to find a installation method which is stable and very close to the SD install for stability.

I used the latest pi image and followed the instructions on here to get HASSIO installed on it.

Point me to image you use and I will see if I can figure it out…

Sound good! :slight_smile:
I like to install the standard one from for the Pi4.
it doesn’t matter if its 32 or 64 bit.

The Hassio version of the raspberry pi is running on top of a custom version of linux. It doesn’t appear that there is any support for USB boot for the Pi4 at this time.

The link that I followed:

Even though I do have pi3 to test on, not sure I would follow this as it permanently alters the bios configuration.

At this point I am sticking with the install procedure at:

You kind of have to read between the lines for the preparatory commands to execute; but use the final part defined by “SKAL” for the rpi4.

2020-05-15 Add pieeprom-2020-05-15 beta with USB boot

2020-06-03 Bootmode tweaks and fix issue with > 4TB drives - BETA

2020-06-12 Improve handling of multiple bootable USB devices


Thanks for this,
So what’s the current status ?
Will it boot a image from the ssd without an SD ?
Or does it only boot pi OS ? (new name for raspbian)
Are there instructions someplace ?
Where are the images / files ?

It looks like it has been moved in to stable status today, so shouldn’t take long.

What is status now?

I think you can do it now, I did try. I think the process is:

  1. updating erom(or something like this)
  2. flash Hassio supervised to SSD
  3. connect and boot.

I waiting for a ssd, to arrive from China, before I test.

No, SSD boot of Hassio is not working yet. I do wish that this was supported though.

It is en BETA ( .
Have it running from a USB stick without any problems.

Can I flash this version directly to a SSD?

First I updated the RPI4 eeprom to support USB boot. Then I flashed the beta version to my USB. I used a different USB to setup the wifi.
Currently Im running on a USB 2 8gb memory stick witch works great.

Edit: There are some talks that only the 64bit version is currently working. I have not tried the 32bit so cannot say if this is correct

1 Like