Install Hildebrand DCC Glow Integration into HA in Synology Docker

Hi - newbie here.

Am at the start of exploring HA. Have installed it in a container on my Synology DS220+ using Container Manager and instructions from MariusHosting. I’m now playing with trying to get an energy consumption feed into HA using the Hildebrand DCC Glow Integration. I’ve got the Glow app installed on my iPhone with the data feed working ok.

I’ve then tried following the Github instructions for a manual install (I don’t have HACS because it’s not available in a container installation), but with no joy - presumably because the instructions don’t work for a containerised version of HA.

So, my first question is: has anyeone else managed to get this working?

And the second question, assuming the answer to previous qeustion was ‘yes’, is: how?

It should work fine

You probably didn’t make it executable

chmod 755

Thanks for response. It’s encouraging that it should work.

Perhaps if I describe what I’ve done, you could point to where I’ve erred?

I’ve attempted to follow the Manual Installation instructions here.

  1. Firstly, my container doesn’t have a folder “config/custom_components/” - so I created both through the File Station interface on the Synology

  2. I then downloaded and placed the file / folder structure in this location as instructed on GitHub.

  3. Finally, I restarted HA and went to the Integrations menu, clicked “Add integration” and looked for “Hildebrand Glow (DCC)” but couldn’t find it.

Which stumped me!

You refer to making it executable - can you advise where / how I would do that? Is there anything else that I’ve done wrong / not understood? Any pointers would be greatfully received!

Although my installation is different, I think the custom_components folder should be in the same folder as .storage. The homeassistant folder is your config folder.

1 Like

Thanks again for response. Tried moving the folder and restarting, but no joy I’m afraid.

I didn’t mean in .storage - in the same folder so in the homeassistant folder

Joy! It worked. Thanks a million!