Install Homeassistant-Supervised on Raspberrypi 5 4GB

That’s my tutorial on how to install Homeassistant-Supervised on Raspberry Pi 5

Put the following 3 lines in your config.txt-File in the boot folder of your Raspberry Pi 5

apparmor=1
security=apparmor
kernel=kernel8.img # at least required if you use pi4 as homeassistant version

Download and Install Docker-ce by using a utility tool for easier installation

sudo wget https://<raw.githubusercontent>.com/BangerTech/The-BangerTECH-Utility/development/bangertech_utility_arm.sh # can’t provide links because of restrictions. Just remove the “>” and “<”

Change the permissions of the tool

sudo chmod +x bangertech_utility_arm.sh

exec the utility

It takes about 20 seconds to start

sh bangertech_utility_arm.sh

Now the main installation of docker-ce

It might take up to a minute. Don’t cancel at any time!

By installing e.g. Portainer Homeassistant might not start or will print out an error

Installing after restoring your backup - if you have one - works

You can navigate with the arrow keys, select or deselect with the space bar and finish by hitting enter

By getting prompted if you want to reboot, hit enter to reboot

In the following fields, you should only pick “Docker+Docker-Compose” and then follow the Steps presented by the Tool

You can check if everthing with docker works by exec the following command

sudo docker run hello-world

change into root-mode

sudo su -

Update every thing

apt update && apt upgrade -y

Now install all the required Dependencies by exec the next two commands

might need restart depending on firmware. Do if prompted so

1. Command

apt install apparmor jq wget curl udisks2 libglib2.0-bin network-manager dbus systemd-journal-remote -y

2. Command

apt install
apparmor
cifs-utils
curl
dbus
jq
libglib2.0-bin
lsb-release
network-manager
nfs-common
systemd-journal-remote
systemd-resolved
udisks2
wget -y

Install os-agent

Today, the newest verison is 1.6.0

If you do that in the future, you may want to check for a newer version. To do that, go to the following GitHub page and click on releases

https://<github.com>/home-assistant/os-agent/releases

Scroll down a bit and right-click on the asset of the latest version called os-agent__linux_aarch64.deb

Then click on copy link address and put it in the command below

wget

Install os-agent by exec the command below

Using Tab, the file completes itself after a few characters

dpkg -i os-agent__linux_x86_64.deb

Install the newest homeassistant-supervised version

Today, the newest version is 1.6.0

Here you automatically download the latest version

wget -O homeassistant-supervised.deb https://<github.com>/home-assistant/supervised-installer/releases/latest/download/homeassistant-supervised.deb

Install Homeassistant

If it fails, it’s not enough to just rm os-agent and homeassistant-supervised.deb

The only solution that I have found was to reinstall your entire os and follow the steps above again

That might not be right. So let me know if there is another way to get it to work!

During the Installation, you get asked “Select machine type”

At the day as I’m writing this, you have to select “raspberrypi4-64” or “raspberrypi4-32” if you have a 32-bit OS

In the future, there might be a pi5-64bit version. If there is, then use that one.

apt install ./homeassistant-supervised.deb

If near the end of the output you see following everything worked

[info] Install supervisor startup scripts
[info] Install AppArmor scripts
[info] Start Home Assistant Supervised
[info] Installing the ‘ha’ cli
[info] Switching to cgroup v1
[info] Within a few minutes you will be able to reach Home Assistant at:
[info] http://<homeassistant.local>:8123 or using the IP address of your pi # remove the “>” and “<”
[info] machine: http://<Your Pi’s IP Address>:8123

Restart your entire system with the following command

It’s not enough to have the created docker container restarted

reboot

Access your Homeassistant-WebGUI by entering the following in your browser’s address bar

Make sure to use http and NOT https

You can also use the hostname that you set, like in the second example

You can find out what IP is assinged to your Pi by using “ifconig” and looking at the used interface in the second line at the point “Inet”

http://:8213 # remove the “>” and “<”

E.g.http://<192.168.2.5>:8213 # remove the “>” and “<”

http://<Your Pi’s hostname>:8213

Standard hostname is raspberrypi

E.g.http://:8123 # remove the “>” and “<”

You may check out my right formatted and updated version on my GitHub here:

What host OS are you using? I tried with Raspberry Pi 5 OS 64 Bit which install seamless but when I run the supervisor setup I get an error message saying only Debian is supported. Didn’t find any native Debian distribution yet for the Pi 5…

I’ve described my used OS at the top of the Github Repo. I did all this on Raspberry Pi OS 64bit, which is pretty much Debian 12 Bookwirm. For that I used the Pi Imager.
I didn’t experience that error in my own testing.
Could you please provide which Tutorial you used? That own here in the community or the updated one in my Github Repo?

I started with a fresh install of raspberry pi os 64 bit for rpi5 burned with Pi Imager
Using the tutorial on the github repository …github.com/HuckleberryLovesYou/Homeassistant-Supervised-on-Raspberry-Pi-5/
I selected machine type “pi5-64bit” version.
Everything installs smoothly however exit of the process with an error:
Installing new version of config file /etc/init.d/docker …
Setting up homeassistant-supervised (1.7.0) …
[info] Reload systemd
[info] Restarting NetworkManager
[info] Enable systemd-resolved
[info] Restarting systemd-resolved
[info] Set up systemd-journal-gatewayd socket file
[info] Enable systemd-journal-gatewayd
[info] Start nfs-utils.service
[info] Restarting docker service
PING checkonline.home-assistant.io(2606:4700:20::681a:5ee (2606:4700:20::681a:5ee)) 56 data bytes
64 bytes from 2606:4700:20::681a:5ee: icmp_seq=1 ttl=58 time=616 ms

checkonline.home-assistant.io ping statistics —
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 615.776/615.776/615.776/0.000 ms
[info] Install supervisor startup scripts
[info] Install AppArmor scripts
[info] Start Home Assistant Supervised
[info] Installing the ‘ha’ cli
[info] Switching to cgroup v1
[info] Within a few minutes you will be able to reach Home Assistant at:
[info] …homeassistant.local:8123 or using the IP address of your
[info] machine: …192.168.68.19:8123
[warn] A reboot is required to apply changes to grub.
Processing triggers for man-db (2.11.2-2) …
Processing triggers for libc-bin (2.36-9+rpt2+deb12u4) …
*Scanning processes… *
*Scanning processor microcode… *
*Scanning linux images… *

Running kernel seems to be up-to-date.

The processor microcode seems to be up-to-date.

No services need to be restarted.

No containers need to be restarted.

No user sessions are running outdated binaries.

No VM guests are running outdated hypervisor (qemu) binaries on this host.
N: Download is performed unsandboxed as root as file ‘/root/homeassistant-supervised.deb’ couldn’t be accessed by user ‘_apt’. - pkgAcquire::Run (13: Permission denied)
root@raspberrypi5:~#

Not really. Raspberry Pi OS is a Debian derivative:

“A Debian derivative is a distribution that is based on the work done in Debian but has its own identity, goals and audience and is created by an entity that is independent from Debian. Derivatives modify Debian to achieve the goals they set for themselves.” (Source: Debian – Debian derivatives ).

A PR has been merged into the Supervised installer that will block any attempt at installation on an OS that is not supported, such as Raspberry Pi OS or Ubuntu. You must run Debian, not a derivative.

Look at ADR 0014 and take a special note about the section pointing out: “Supported Operating System, System dependencies and versions”.

1 Like

“Pretty much” isn’t Debian Bookworm, it’s a derivative and will likely cause problems showing ‘unsupported’ or ‘unhealthy’ now, or in the future.

Please read ADR-0014 - Debian 12, no derivatives.