Install latest core version on RPI

I have an RPi v3 with Home Assistant Core.
For some reason pip3 finds as latest version the 2023.1.7 and I cannot upgrade to the latest one.
While from a linux machine I can install the latest version 2023.9.1
More over pip3 claims that it refuses to upgrade pip to the 23.2.1 because home assistant is requesting the old version

Does your Pi3 run Python 3.11 ?

1 Like

Thank you @francisp
I am using default system packages, where the latest python is version 3.9
I’ve tried to install manually 3.11.5 and test however the compilation fails with:

  PYTHONHOME = (not set)
  PYTHONPATH = (not set)
  program name = './_bootstrap_python'
  isolated = 0
  environment = 0
  user site = 0
  safe_path = 0
  import site = 1
  is in build tree = 0
  stdlib dir = '/usr/local/lib/python3.11'
  sys._base_executable = '/usr/bin/python3'
  sys.base_prefix = '/usr/local'
  sys.base_exec_prefix = '/usr/local'
  sys.platlibdir = 'lib'
  sys.executable = '/home/bnv/hass/Python-3.11.5/_bootstrap_python'
  sys.prefix = '/usr/local'
  sys.exec_prefix = '/usr/local'
  sys.path = [
Fatal Python error: init_fs_encoding: failed to get the Python codec of the filesystem encoding
Python runtime state: core initialized
ModuleNotFoundError: No module named 'encodings'

Current thread 0x0000007fae934800 (most recent call first):
  <no Python frame>
make: *** [Makefile:1217: Python/frozen_modules/abc.h] Error 

What (old) OS do you run at all? Easiest might to just get a recent OS as base which support a recent python with (active) support or directly opt-in for HaOS maybe?

Probably Bullseye.

Vlachoudis, try upgrading to Bookworm, comes with Python3.11

@francisp you’ve hit bullseye :slight_smile:
Many thanks, I am upgrading now
and it worked ok!