Install on a NUC, help please

I have been running HA on a Raspberry Pi for a few weeks now but I decided to move to a NUC because of issues with the SD card getting corrupted. Installation on the RP was simple, write the file to the card insert and power up, HA installs itself.
I followed the same procedure with the NUC file but it does not install. I have read now that the NUC file is not an installer and needs to be installed with this command "gunzip -c /media/sdc1/hassos_intel-nuc-2.12.img.gz | dd of=/dev/sda bs=4M conv=fsync" but then I get a bunch of errors before the install comes to a halt.
Is it not possible to do a simple install to a NUC? I really dont want to get into complex Linux installs, I am coming from Windows and I’m not sure at my age I can learn a new skill soon enough :slight_smile:
Really appreciate any help that recognises my limitations, thanks.

Do you have a USB SSD external reader? Pop the SSD into that, plug it into the usb port of pc, copy the files onto the SSD, then pop the SSD back into the nuc and boot.

Have you tried what the documentation suggests in step 2 and write the gzipped disk-image file to your SSD using balenaEtcher?

  1. Install Home Assistant:
  • Flash the downloaded image to an SD card using balenaEtcher. If using a Pi, we recommend at least a 32 GB SD card to avoid running out of space.

That long-winded command string is the equivalent of what Etcher does. It’s not the same as copying files to a formatted disk. It destructively overwrites any existing information on the target disk with the contents of the gzipped image file.

I havent tried that idea of writing directly to the ssd, would have to pull it out of the nuc and then get a sata/usb cable but that may have to be the next step.

Can you post a link to the intallation instructions you were following?

I was following this.

Step 4 says to burn the image to the target drive using Etcher.

@peejay. The updated method is linked here My steps to success for on Intel NUC. That uses a live Linux distro for the whole install which is how I’ve done my last two installs and it’s much easier. You ideally need 8GB RAM to do this though if you’re going to do it all inside the live image.

I only have 2 GB RAM so I guess I should pull the drive and use Etcher and a cable to wrte to the SSD. The SSD currently has Ubuntu installed and shows two partitions, sda1 and sda2, should I repartition first?

A Linux live will run perfectly fine on 2gb of ram. Even X will, but maybe a little slow.

@peejay did you get this up and running? I’m considering a move from my pi to something more sturdy (NUC) but not interested currently in going down the Linux road (just not enough time to research and learn).

From what I’ve read, to use Home Assistant (OS) in a similar manner to a pi, you need to flash the image to the NUC ssd instead of a USB stick?

(yes, yes, I know people will say its a waste of the NUC and I can’t do anything else with it - but I’m happy with that decision)

I tried flashing my entire NUC SSD HD, it didn’t work. You may have more success, but I installed Ubuntu Server and ran the supervised installer instead. Works great.

Since Ubuntu isn’t officially supported I would go with a guide like this: Installing Home Assistant Supervised on Debian 10

1 Like

Hi Mike.
Yes, I purchased a cheap NUC with a small SSD and used this guide to get HA up and running.
I dont know Linux but if you can get a RPi up and running you can probably do this, I found it very easy to follow his instructions, mostly you just cut and paste.
I am very happy with my NUC setup now, it has been running smoothly for some months now, a huge improvement over the RPi and the issue I kept experiencing of SD card failure.

1 Like