My steps to success for Hass.io on Intel NUC

Do you mean Home Assistant OS? Hass.io was never an OS.

yes, https://www.home-assistant.io/hassio/installation/

Hass.io was never an OS, and also no longer exists. I think you are confusing it with the old HassOS that is now called Home Assistant OS.

The docs haven’t all been updated since the name change.

It’s super easy to install Ubuntu and then Home Assistant Supervised (Hass.io). Maintenance is very easy.

Yeah, not sure on the nomenclature. At any rate, installing it on a NUC causes the above error being faced.

I did find the following as it relates to another distro but seems to be the exact issue (https://forums.balena.io/t/bluetooth-firmware-failed-intel-nuc7i5-intel-wireless-ac-8265-bt-4-2/1837). Seems the firmware looks to be out of date on the hass img.

The more I read into the above, it seems like I need to inject a library into the Hassio disk image: https://github.com/pop-os/linux-firmware/blob/master/intel/ibt-19-0-4.sfi

Anyone have an idea how this can be done?

Well, for anyone that has been stuck getting your NUC to boot with HassOS, here is MY solution… and it’s super easy: DO NOT USE A NVMe M.2 DRIVE.

After a ton of reading and experimentation I found that swapping out my Samsung 970 EVO Plus with a M.2 SSD, worked perfectly. Also, in my case this is for a NUC8i3 and NUC10i3. If this is in fact true across the board for all NUC models, this should really be documented/fixed.

Hope this helps someone… I’ve seen several of you stuck at the same place as me.

Bingo!

NVME disk now working on Intel NUC

This is what I did:

  1. download https://ubuntu.com/download/desktop, run live (try Ubuntu)
  2. download https://github.com/home-assistant/operating-system/releases/tag/4.5 (notice: Support NVMe & update barebox (#626) @pvizeli)
  3. run gnome disks -> restore disk image
  4. run gparted --> resize last partition

To enable WiFi:

  1. login as root
  2. type: login

nmcli dev wifi connect “SSID” password “password”

Make sure to include “”. This helped me a lot: https://unix.stackexchange.com/a/444433

4 Likes

Is not needed, will be done anyway on first start

I’m assuming from this that you imaged your existing HA install first and then just copied it back to the new NVMe? Is this easier than doing a backup and restore?
EDIT. Sorry, re-read. So your using Gnome to write the downloaded disk image to the NVMe. Got ya now. That’s easier than my method. Will give that a try.

Thanks for this. Huge help. A tip for those trying this.

  • Wipe the partition first if the disk was previously used as mine was, otherwise the restore does not work. I had Proxmox on mine prior and the restore keep coming up with an error until I booted back to Windows, wiped the drive and created a new partition.
  • It’s best to have downloaded and unzipped the image file prior to booting into Ubuntu and have this on another USB stick. That will provide the easiest method of locating the *.img file for the restore process.
  • I’ve noted that the dev version does not seem to have a ‘reload’ icon for the snapshot page. Not sure if this is 0.109.3 or the HassOS. Once you’ve copied your backup files to the backup folder, you’ll need to reboot the hardware for these to be discovered.

The gnome-disks idea, I just read it somewhere. When switching from RPI to NUC I just thought let’s try this…

I’ve been trying to find out where I read it, but can’t seem to find it again.

But if anyone benefits of this I’m glad to have shared it here

2 Likes

I did all the required disk operations within Ubuntu Live (20.04) disk. Didn’t even pull out disk.

I also did download of the image and extract within Ubuntu Live OS. I have 16 gigs of RAM so it was enough for download and extracted image :wink:

I also didn’t have the reload icon. You can either do reboot or first backup and then file replace. Either way worked for me.

I have this running for a couple of days now and everything seems OK.

I don’t have nvme, just an m2. But my system has been running fine for a few months now.

I also did this straight on the nuc, except the dl part. had the image as file on the bootable usb. Did not unzip.

Who can help me with this? I followed all the steps and came to this. Into what do I need to restore it? What is ‘it’ and how to do it?

Can someone get a more detailed version of the last few steps of this process?

Thanks in advance!

‘it’ is your disk on which you want to restore the image.

Since you are running this on a nuc I presume there is just one disk? I did this on my m2

So on a root terminal
run gnome-disks
restore image/disk (under the waffle icon)
choose your disk
overwrite contents (you will be erasing the current disk)
I started gparted and checked bootable flag on the disk as well

1 Like

Just bought a NUC5i3, 8Gb/128Gb M.2 and using gnome-disks did not worked for me, it booted but was stuck before the end of the boot. I downloaded Balena Etcher and HassOS from Ubuntu live and then flashed HassOS image directly to SSD. Worked perfectly!

Worked like a charm.

Last question(s). Now I need to connect it to my wifi, anyone got any commands for that. Can’t seems to get anything right there. Thanks!

EDIT: Done!

I have the following Home Assistant set up working flawlessly for 15 months, managing 18 devices and over 200 active entities

NUC with i5-5300U | 2.3GHz
8GB RAM
Windows 10 64bit
VirtualBox 6.1 / VM configuration below

For performance improvement, I’m working on upgrading the a HA setup to NUC i5-6260U | 1.8GHz | 16GB RAM running Ubuntu 20.04 with Virt-Manager but am still unable to get working in a stable & consistent manner see post

i219-v NIC. NUC10i7, running Hassio 4.8. Not recognizing network/IP address =/

The NUC is on my desk, SSD drive inside. No usb/sata adapter at hand, can’t use balena and will try gparted method. How/when can I set the fixed IP address for hassio?

Mines not even giving me a IP address. Which nuc u running