Install on Unbuntu 20.04.5 or 22.04.1

Hi,
My previous install was on a unbuntu machine running for about 3+ years. Unfortunately the latest do-release-upgrade to 22.04.1 has broke that install.

I have some new hardware and figured it would be a good time to do a clean install, then restore a recent backup.

Im trying to install supervised with a recent supported image of ubuntu but cant get past:

$sudo dpkg -i homeassistant-supervised.deb
[error] Ubuntu 20.04.5 LTS is not supported!

Yet I know the machine (that is now broken) was running this version of ubuntu previously…

So my question:
Which version of ubuntu can I download that is still in LTS and will pass the homeassistant OS validation check?

None. Ubuntu is not a supported OS. Ubuntu is a derivative of Debian and as the ADR on supervised states the only supported OS for supervised is:

Debian Linux Debian 11 aka Bullseye (no derivatives)

So the installer will only run on Debian 11, not Ubuntu.

Note that this is not the Home Assistant OS check, this is the supervised check. You are not running Home Assistant OS as that would be your operating system (instead of Ubuntu or Debian or anything else). If you do not want to use HAOS or Debian as your operating system then your options are:

  1. Install HAOS in a VM
  2. Switch to a Container or Core install.
  3. Find a version of the supervised installer before this PR, install it and then attempt to keep everything up-to-date manually without the help of the installer. Along with handling other issues caused by running in an unsupported setup.

Thanks - I think the link to the pull request will give me a path forward.

just to confirm release 1.3.1 did the trick if anyone else doesn’t want to run another flavor of operating system on their networks.

WARNING! DON’T DO THIS UNLESS YOU ARE ABSOLUTELY SURE WHAT YOU’RE DOING! If you run into any issues, please don’t file a bug report. Keep in mind it’s not officially supported.

I’ve made a code analysis on the homeassistant-supervised.deb package and found an OS check bypass mechanism:

Once again, use this only if you REALLY know what you are doing and don’t whine to anyone if it doesn’t work or breaks something.

sudo BYPASS_OS_CHECK=true dpkg -i homeassistant-supervised.deb

Hope it helps anyone as it helped me.

For what its worth, last month I rebuilt a new HA system on a NUC. It runs HA as a QEMU/KVM based VM guest on an Ubuntu 22.04 host.