Install stuck at "Installing Home Assistant"

I have a Raspberry Pi 4 4GB. I had sucessfully installed HA by flashing an image to an SD card using the process described in the website. It worked well and I was loving HA and my new automated life until i clicked on update 3 days ago. HA stopped responding and I couldn’t connect to it with SAMBA or CLI. I had a recent backup of the configuration so decided to do a clean install then restore the configuration.

I used exactly the same procedure as the first time, the only difference is I’m using the new OS version. I have tried multiple times using the instructions here . Every time it gets to the point where I can connect to HA with a browser. The “Preparing Home Assistant” message comes up, but it never gets past that point. I have waited up to 12hours.

I have tried version 5.8 64 and 32 bit images. Also tried the 5.9 version in case there were some bug fixes. No change.

I can see on my router console that HA is connected to the router and I can ping it’s IP from my PC.

I connected a keyboard, mouse, monitor. The system boots successfully to the point where I get the Welcome to Home Assistant message. I can login using root and get the welcome to home assistant command line message.

After a few days of frustration, I decided to install OpenHab Habbian OS. That worked perfectly which proves there is nothing wrong with the PI, SD card, network etc. After about an hour fiddling with OPenhab I realize why most people are choosing HA and went back to trying to get HA working.

Here is a shot of the logs, stats and info of the install.

I ran the Core Update command and get Command completed successfully reply. I assume this means it is able to connect to the internet to check for updates.

I’m out of ideas. Greatly appreciate any suggestion to fix or troubleshoot this

Downgraded to 4.2 by running command ha os upgrade --version 4.20.

Now it works. My conclusion is that 5.8 image has some bug that prevents it working on RPi4