Install suddenly doesn't work, how to do disaster recovery

Have been running the same config for weeks with no problem, was going to tinker with it yesterday, but the hass-io-panel didn’t work. So i tried restarting HA trough the webinterface, but i got an error message in the log. I don’t remember it now though. Restarted the host OS, and now nothing works, can’t access the webinterface, the samba share is down, no automations works and so on. Had to revert to a snapshot of the virtual machine from December. But how do i do disaster recovery here? I have some newer snapshots in HA, but how do i reach them when HA doesn’t work? Where are they stored? What is the best way to go about it, just make a brand new virtual machine with a fresh HA-install and restore from a snapshot there?

I don’t know how you installed hassio, but if you did a generic install then the backups are located in

always make server backups

It won’t help you now, but have a look at the google drive backup add-on.

I did, that is why i could revert to the older snapshot. But I am looking into what is the best way to move forward to recover the HA-install.

Thanks, what would you advice? A clean virtual machine and then restore the snapshot on that?

If you can get to the snapshot, it might be the fastest way to go.

Is there anything i can do to prevent something like this in the future? It is a bit disconcerting that the install can just totally fail out of the blue like this.

What virtual machine are you using?

I am running ubuntu on a windows server 2012 host.

if sambashare isn’t working the issue is outside home assistant core.

I had a similar issue last night - I run hassio on Ubuntu, and it seems to be that it’s using outdated startup scripts. As per @frenck:

Running the install instructions from our website again will fix this issue.

Installation - Home Assistant

Running the installer again, preserves data.

Thanks a lot, just to be crystal clear here, “running the install installer again” would here be

curl -sL "" | bash -s"

and nothing more?

I have two small additional questions, can i get it to install a specific version? And how do I find out what version i used to have installed? (I don’t quite remember)

Yes, I believe so. I used some of the commands further up the page, and only saw the warning against doing so after the fact (I’m going to rebuild the whole VM or switch to hassio image to avoid any issues).

As you’re using a VM, best thing to do is take a snapshot in Hyper-V before making any changes, that way you can roll back if you need to.