Install Supervised/Supervisor on Raspberry Pi4 with Docker installation

Does anyone figured out, how to fix rpi.gpio ?
Is there any way to update RPi.GPIO to 0.7.1a4 on core container ? That seems to fix the problem with gpio on debian (atleast on host).

thanks man. I will reinstall.

Thanks man, I will check it out. I thought supervised was a software component.

I use RPi for Plex Server and Retropie, it is running raspbian, to be honest the only container i used was home assistant. Apparently I made the wrong choice to use docker container, instead of just installing it directly to raspbian directly without docker containers. I will reinstall it.

Thanks all for the feedback. I will reinstall home assistant when I have patience :rofl:

I trying to install HA Supervisor but I have a small issue :face_with_raised_eyebrow:
When I start the installation script, I receive the fallowing message:

pi@Silax-RaspberryPi:~/Desktop/test $ sudo bash --machine raspberrypi4-64
[warn] If you want more control over your own system, run
[warn] Home Assistant as a VM or run Home Assistant Core
[warn] via a Docker container.
[warn] If you want to abort, hit ctrl+c within 10 seconds...
[warn] ModemManager service is enabled. This might cause issue when using serial devices.
[info] Creating NetworkManager configuration
[warn] Changes are needed to the /etc/network/interfaces file
[info] If you have modified the network on the host manualy, those can now be overwritten
[info] If you do not overwrite this now you need to manually adjust it later
[info] Do you want to proceed with overwriting the /etc/network/interfaces file? [N/y]
[info] Replacing /etc/network/interfaces
[info] Restarting NetworkManager
PING ( 56(84) bytes of data.

--- ping statistics ---
1 packets transmitted, 0 received, 100% packet loss, time 0ms

[info] Waiting for - network interface might be down...
PING ( 56(84) bytes of data.

--- ping statistics ---
1 packets transmitted, 0 received, 100% packet loss, time 0ms

[info] Waiting for - network interface might be down...

It seems that I do not have internet access through the docker .

Do you have any advice how to fix this problem?


I’m using a raspberry pi 4 with pi os buster

I installed following most of the instruction in the video, How to Install Home Assistant Supervised - OFFICIAL WAY - YouTube , already had dockers installed with a greater version than requested, 20.10.9, updates & upgrades done

ran the commands:

sudo apt-get install network-manager apparmor-utils jq -y

sudo reboot

sudo curl -Lo

sudo bash --machine raspberrypi4

At the end of the installation it says to connect:

And there’s nothing there to connect

Only the observer is listening to ports:
docker ps
fb9a411becb9 “/init” 21 minutes ago Up 21 minutes hassio_multicast
d33815e8b462 “/init” 21 minutes ago Up 21 minutes>80/tcp, :::4357->80/tcp hassio_observer
7fea187ba5aa “/init /bin/bash -c …” 22 minutes ago Up 21 minutes hassio_cli
6d5f928ff4dc “/init” 23 minutes ago Up 23 minutes hassio_audio
7b4bdae7f210 “/init” 23 minutes ago Up 23 minutes hassio_dns
5c6ec67d686e homeassistant/armv7-hassio-supervisor “/init” 38 minutes ago Up 22 minutes hassio_supervisor

searching for listening ports, no port 8123 also:
netstat -lnt
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0* LISTEN
tcp 0 0* LISTEN
tcp 0 0* LISTEN
tcp 0 0* LISTEN
tcp 0 0* LISTEN
tcp6 0 0 :::22 :::* LISTEN
tcp6 0 0 ::1:631 :::* LISTEN
tcp6 0 0 ::1:6010 :::* LISTEN
tcp6 0 0 ::1:6011 :::* LISTEN
tcp6 0 0 :::4357 :::* LISTEN

Only the observer port and page works.

Home Assistant observer
Supervisor: Connected

What am I missing?

Thanks in advance

First of all, format your post correct.
Second, don’t use (outdated) youtube video’s
Third , pi os is not supported, only debian
Fourth, did you install os-agent ?

Sorry about the format, it’s been a few years since my last post
It’s a raspberry pi4, I think it can it can handle home assistant and more, that’s why I didn’t want to install HA OS.
not yet, haven’t installed the agents
I’m comfortable with linux and networking, dockers not so much.
Any debian will do?
also read somewhere that home assistant and kodi don’t get along, is that true?


Debian. Buster is only supported until beginning December (there was 4 months deprecation time), so better install Bullseye.
Without os-agent installed your supervised installation will not work.

I gave up and installed HA OS and it’s working

Thank you for your help :smiley:

1 Like

Out of curiosity, what else do you plan to do on the pi4, outside of HA? Looking for ideas here.

Most of what I had planed to do will be done with the nas i just bought

A media player, nas, firewall, next cloud, download station and I’m sure I’ll think of something next

Can’t have kodi with HA OS, right?

I am running in a raspberry pi 4 and I have tried this 3 times but can’t get it to run. I get positive results until the last step (sudo bash --machine raspberrypi4). Every time I run the command it says “ line 1: 404:: command not found.”

Same for me. The file isnt there any more

Seems like it got deleted Delete · home-assistant/supervised-installer@ece9fcc · GitHub

Hi all,
I installed the supervised like one-two weeks ago in raspbina 64bit. The only problem was with grub, that raspbian don’t use.

I follow this guide:

But it is not fully correct. The steps I follow (more less) were:

  1. sudo apt-get install jq wget curl udisks2 libglib2.0-bin network-manager dbus -y

  2. sudo reboot now

  3. Install last agent version (currently 1.2.2): Release 1.2.2 · home-assistant/os-agent · GitHub
    a. Raspbian 32bit installation: wget
    b. Raspbian 64bit installation: wget

  4. Install the downloaded .deb. For example, for 32bit version: sudo dpkg -i os-agent_1.2.2_linux_armv7.deb

  5. Check if is correctly installed: gdbus introspect --system --dest io.hass.os --object-path /io/hass/os

  6. wget

  7. sudo dpkg -i homeassistant-supervised.deb

1.1.1 version will finish in an error related with grub: Switch to cgroupv1 by ikifar2012 · Pull Request #201 · home-assistant/supervised-installer · GitHub

To fix, after the first installation, change: /var/lib/dpkg/info/homeassistant-supervised.postinst
1. sudo nano /var/lib/dpkg/info/homeassistant-supervised.postinst
2. Comment the lines at the end of file. See the github comment.

3. sudo apt autoremove
In this case, the installation will end without error.

Now we need to activate AppArmor:

  1. sudo apt install apparmor-utils

  2. sudo nano /boot/cmdline.txt

  3. Add lsm=apparmor

  4. sudo reboot now

  5. Check AppArmor

  • aa-status
    Need to print a result like: apparmor module is loaded.

  • aa-enable
    Need to print a result like: Yes

1 Like

Hi, I have followed the above steps for HA Supervised installation, but I get the error:

dpkg: dependency issues prevent configuration of homeassistant-supervised:
homeassistant-supervised depends on os-agent.
homeassistant-supervised depends on systemd-resolved; however:
`systemd-resolved’ package is not installed.

dpkg: error processing homeassistant-supervised package (–install):
dependency problems - left unconfigured.
Errors were encountered while processing:

I tried to install the `systemd-resolved’ package but it seems to be deprecated for the raspberry pi 4.

My raspberrypi 4 has the OS version from the Raspberry web, which is Debian 11.

Has anyone been able to solve this problem,


See this topic:

Thank you.

I will follow this topic to see if I can install HA Supervised because otherwise I see no way to install add-ons.