Install zwave on Snyology nas

i’m triing to install zwave on synology nas. Anyone has tried this? apt-get is not working on synology :frowning:

What version of DSM are you running?

I recommend using Docker to install it.

+1…use Docker


I am more or less on the same boat.
I am using docker. just 2 quick questions for someone on Synology + docker

  1. do you found a way to launch it container from the gui or jsut using the SSH (I cant map the USB stick if I use the GUI)
  2. did you managed to get OZCP working on synology+docker? how? no matter what i do, it doesnt seems to work.



Here’s the command I use to run Home Assistant with my z-wave USB

 docker run -itd  --restart=always--name home-assistant -v /volume1/systems/apps/homeassistant/config:/config --net=host --privileged --device /dev/ttyUSB0 homeassistant/home-assistant

For open zwave, I use Domoticz via Docker. I first close down HomeAssistant by running

docker stop home-assistant

Then I run a fresh Domoticz container using

docker run --privileged --name domoticzorig --net=host --device /dev/ttyUSB0 -d -p 8080 -v /volume1/systems/apps/domoticz/open-zwave:/daedalus quantumobject/docker-domoticz

Domoticz has an instance of OpenZwave Control Panel you can use to configure your devices. Then be sure to download the config file from Domoticz, and upload it to HomeAssistant’s config directory.

Once you’ve got the HomeAssistant container up-and-running with the command line, it should add it to the Docker GUI. You can then start and stop HomeAssistant using that.

thank you Phil.

I run a similar command line, except i dont run it on --privileged.
In my case, every time I stop the container, it loses the --device configuration, so when i re-start it, I cant see the USB stick anymore. so i always use the CLI to get the full command.

I notice that you are using a different domoticz container, i will try to use our version. the one I use have difficulties to save the config file, so i cant download without some pain.

other than that, I am very happy with Docker on synology.