Installation - discovery module error


I have a basic installation running on a Raspberry / Dietpi Jessi and while manually running hass netdiscovery throws an error:

INFO:homeassistant.util.package:Attempting install of netdisco==0.5.2
Command "/usr/bin/python3.4 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-qjwzdhvu/netifaces/';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-l247o9kw-record/install-record.txt --single-version-externally-managed --compile --home=/tmp/tmpkxtksqw0" failed with error code 1 in /tmp/pip-build-qjwzdhvu/netifaces
ERROR:homeassistant.bootstrap:Not initializing discovery because could not install dependency netdisco==0.5.2

I have completely uninstalled home-assistant, reinstalled it but the error persists. I am installing as a user, but installing as root did not change the outcome here. Any clues how to debug this?

Many thanks!

I am have the same error. I am running it on Windows 7.

what version of python are you running?


I think that may be the problem. If you look at your error msg, it has hard references to 3.4.

I have the same problem. But I am using python 3.4 on my Raspberry Pi.

INFO:homeassistant.util.package:Attempting install of fritzconnection==0.4.6 Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-dxe8g54q/lxml/';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-iz4bvkt5-record/install-record.txt --single-version-externally-managed --compile --home=/tmp/tmp9t8b73ac" failed with error code 1 in /tmp/pip-build-dxe8g54q/lxml

Thanks jbags81 - it looks like I have 2.7.9 and 3.4.2 installed…
Is that the issue? If so what are my options to fix this?

[code]root@deepi:~# python3
Python 3.4.2 (default, Oct 19 2014, 13:31:11)
[GCC 4.9.1] on linux
Type “help”, “copyright”, “credits” or “license” for more information.

root@deepi:~# python --version
Python 2.7.9


Have you tried installing the dependency manually?

pip3 install --user netdisco==0.5.2

or if installing as root

sudo pip3 install netdisco==0.5.2

Thank you Martin, it is working now!