Installation on Fedora, invalid user error

Hi all,

Getting an error when trying to set the permissions on the folder;

sudo chown -R user:group /opt/homeassistant

Says that user:group is an invalid user. Do I have to put my actual user in there.

Though you would think if that the case it would have been specified?

Ok so it looks like something generic that I need to replace user:group with something.

Very disappointing that your official instructions dont advise what to do here :frowning:

I cant even find that cmd in Google.

If its username:groupname that should be explained please, and what would be the group?

I have tried the logged in user, but im still getting the same error.

The group of the user you’re using for home assistant :wink:

Try creating the user like this:

sudo useradd -rm homeassistant -G dialout,gpio

Then use

sudo chown -R homeassistant:homeassistant /opt/homeassistant

Thanks so much, but I gave up! Trying to install in a docker now.

Someone should really update the wiki to reflect the actual instructions for those that are not native Linux users.

Thanks again!

Such an edit has already been submitted, based upon the feedback in your post :wink: