Installation on OpenMediaVault in KVM, netplan troubles


I am trying to install HA on my OMV6 server. I first tried using docker, which worked pretty well except that without addons I cannot integrate my Eufy security cameras. So then I tried to install HAOS through KVM using this awesome guide. I start getting into troubles while setting up bridges using netplan. I’ve tried about a million configs but nothing worked. I either couldnt access HA webserver or I blocked my pihole, which runs in a docker on the same server and acts as my DNS and DHCP resulting in nothing working at all.
This is my netplan config i need to add the bridge to it:

  version: 2
        macaddress: a8:a1:59:9e:49:71
      dhcp4: false
      dhcp6: false
      link-local: []

How can I add a bridge to it to be able to access HA webserver on the KVM without blocking PiHole (which has IP
This is way out of my league so dont be too harsh please :slight_smile:

what issues did you have with HA as a docker?

I’m using HA in a docker, with OMV as the base OS… I have no issues adding integrations, HACS, and addons… once installed, its just a bare install with a few things… you have to add everything you want…

if you need help with the docker install, let me know…

1 Like

As far as I know, the only HA version you can install in a container is the core version. So i installed that but it does not support add-ons nor supervisor as it says in This link. How did you manage to get a version that supports add-ons to work with docker?

Did you read the comments in the guide thread?

There were a few different approaches people used. It’s been forever since I did this, so my memory is a bit hazy, but I can say that my current netplan is:

# This is the network config written by 'subiquity'
      dhcp4: true
      dhcp4: true
  version: 2
      dhcp4: yes
             - eno1
        stp: true
      accept-ra: no
      id: 40
      link: eno2

that was set up as described. The Ubuntu system is running on, and I have a pi-hole running a, which works fine for me.

Have you tried simplifying? Removing all the config options from the ethernets? I only have the dhcp4: true, letting the router take care of the rest, maybe that approach would work for you?

Side note, but are you sure eufy doesn’t work without an add-on? It looks to me like that’s what the HACS integration can do (and I have used core in docker for many years before moving to VM; HACS is available even if add-ons are not)?

1 Like

Yes, I ready the comments but didnt find anything that would actually help me solve it, probably because I dont understand most of it.

For your suggestion, I let the router take care of DHCP instead of pihole and I tried super simple netplan configs and super complicated ones but if I create a bridge, the ports for pihole become occupied so the container wont launch. But even then, I didnt manage to connect to the webserver of HAOS VM… Obviously, I am doing something wrong, I just don’t know what :slight_smile:

I am not sure if Eufy doesnt work witout add-on, I think I actually mixed up HACS integrations and addons in my head. Either way, I’ve been struggling with this whole process so much that I wanted to switch to VM now before I spend days setting it up and then reach a point when I realize that I need an addon anyway.

I might have to admit defeat, set up core in docker and call it there

I used this one… GitHub - home-assistant/supervised-installer: Installer for a generic Linux system

I’m running what they call a Supervised HA? if I’m calling it right…

I looked at the one you mentioned, and I didn’t like the way it was trying to install… just seemed too backwards…

1 Like

also, I already had docker installed, so I went straight to step 3, then 4… it was easy… much easier that those other directions…

I had no idea that I’d have limited ability with the other instructions… I’ve had no issue adding anything to my install… HACS, addons, integrations… no issues…

I’ve had failed installs of HA in the past, recently returning to it as someone figured out a way around the lack of sunpower integrations… so I decided to try it again… I installed onto a Rpi3b, but not everything worked… couldn’t get NodeRed & Grafana to keep running, kept shutting down after start… decided to try docker, and everything works great, and very very fast…

1 Like

I’m not an expert, but I’m pretty sure anything in docker has the same IP (externally to the network) as the host machine running the container, and then has an internal “docker network” IP that’s typically 172.x.x.x. So if you are blocking ports that are used by a docker container (which a VM shouldn’t do, since it has it’s own IP), you can just change which ports a docker container exposes, externally to the host machine.

But in any case, if HassOS is not available, regardless of pihole, then that’s probably where the issue is.

A few questions that might help getting closer:

  • Do you set a static IP, make an IP reservation for the HassOS VM, or is IP dynamically assigned?
  • Can you see the HassOS IP appear on the network (either in the router settings, or when running nmap from the CLI)? Can you ping HassOS IP?
  • What does virsh net-list show? I saw that at least one person who needed to remove the default bridge before it worked (described here)
  • When you do this with the router as DHCP, does everything else than HassOS and pihole work as expected?
1 Like

I tried every possible option and nothing, that’s including static and dynamic IPs, deleting the default network and bunch of other things I googled. I think i just know way too little about networking to figure this out.

In the end, i installed it again through docker with HACS and it works. Add-ons would be nice to have and i can revisit it when I learn more about networking, but for now I give up. Spent pretty much 3 full days on it

Anyway, thanks y’all for help and tips <3