Installation on RP3 doesn't complete

I’m new to Home Assistant and flashed the RP3 image onto a 32 GB SD card, then plugged it into an RP3. (This is an RP3 I used in the past for home automation using Heyu; it was always reliable.) After waiting a few minutes, I connected to X.X.X.X:8123 and saw the “Preparing Home Assistant” page. Per the instructions, I waited 20 minutes, but nothing happened. After 1 hour I clicked the pulsating blue dot by luck and got the installation log.

I found several access errors, the first being

ERROR (MainThread) [] Can't clone repository: Cmd('git') failed due to: exit code(128)
cmdline: git clone -v --recursive --depth=1 --shallow-submodules /data/addons/core

I copied that commandline my linux workstation, which is plugged into the same router as the RP3, and it worked just fine.

I’ve tried reflashing the SD card several times. I put explicit DNS addresses into my router. The results are identical. At this point, I’m not sure what I can do to resolve the issue.

Thanks in advance for any suggestions.


I’m giving up on HA. It is too hard to do even a basic install or get any support.

In contrast, OpenHab was a breeze to install on an RP. I have decades of linux experience and don’t think I’m stupid, but I can’t figure out how to get HA working.