Installation on Synology Virtual Machine Managager


I don’t think upgrading to 6.0-RC2 (which is the first version with my patch) will cut it, as it is an OVA issue not a filesystem issue.
The only solution for you is to backup (create a snapshot), start a new VM with haos_ova-6.0.rc2.ova and restore your snapshot. Hopefully everything should work from there.

1 Like

Thanks a lot Fredrike. I had hoped it would work automagically but reinstalling is not a problem either.
I think I will wait for the production release rather than using this release candidate 2

If I understand correctly I should visit this page every once in a while and check where the ova link links to (currently 5.13) as soon as it links to 6.0 I should be good to go.

Thanks again!

1 Like

I’m missing a bluepy python library. Is it even possible to install it running HA in a VMM? If so - how?

Very bad news about the new DSM7 for synology, the release candidate was made available today and the notes state:

  1. USB devices (Wi-Fi dongle, Bluetooth dongle, 3G/4G dongle, USB DAC/speaker, and DTV dongle) are no longer supported. If your Synology NAS is currently connected via a wireless dongle, it will be disconnected after the update.

So those who for example use a z-wave or Zigbee USB stick (like me) will have some tough choices to make…

That is known breaking change. It was same for BETA version and listed there in release notes. As always, don’t jump on version 7.0 as soon as it is release and wait for updated drivers from community.

1 Like

I understand from your reaction there will be workarounds. That is good to hear. I assume these will not be ideal (e.g. extra steps that need to be taken, that might break whenever Synology provides updates)?

I have launched a feature request to ask them to keep supporting it. If enough people do so, who knows they might listen.

1 Like

At this point I can’t tell you that - but hopefully it will be something that will hold water between restarts, and biggest wish for me would be that it will survive updates.

Some workarounds currently require running terminal command each restart (that could be run via tasks too), but we have to wait and see.


Hopefully sooner than later. My Virtual Machine has been rock solid so far (thanks!), but I really want to use the new photo app now that Google Photos has killed themselves. Hopefully the ZWave/Zigbee sticks can be made to work with this… I think 90% of my stuff runs off that stick, sigh. Maybe I’ll have to buy a cheap synology to test and figure it out on before I upgrade my main system. lol.

1 Like

I don’t run zigbee( i have all my devices with esp8266), but i explored lidl store’s system a bit and if i’m not mistaken they have zigbee, too and a central receiving station, which is connected to a local network ( not usb), so maybe you should check out in this direction…


I can make sure that the Zwave/Zigbee works if you sponsor me with the sticks… :slight_smile:


The new version of docker 20.10.3-0552 has been released. Will hasio be updated later?

1 Like

Now that is exciting news! I really liked the docker version of hassio. I run the VM version now but I don’t like it half as much as the docker version. I would love to see a new docker version of supervised home assistant. Supported or unsupported…

Would you mind explaining what is it about VM version you don’t like? I did run Docker version, too and i really don’t see any difference between docker and VM version, except that VM version is supported and thus less problematic when installing add-ons. Running speed is more or less the same, i don’t see any difference, HA also runs without any glitch (like docker version)…

I think the transition from Docker to a VM is a step back in technology. First things that come to mind:

  • VM uses more resources then Docker
  • VM uses dedicated RAM, Docker uses shared RAM
  • Docker boots faster
  • VM sometimes looses USB devices after reboot
  • With Docker you have direct acces to the Home Assistant filesystem, no samba share is needed. This makes automating TLS/SSL certificate updates so much easier.
  • Synology VMM requires btrfs filesystem (my volume is ext4)

I know VM is (HomeAssistant) supported and Docker is not. But with the upcoming DSM7 release we will loose (Synology) support for USB dongles anyway. Most of us will have to do some (Synology) unsupported tinkering to keep using Z-Wave or Zigbee dongles. My Home Assistant VM runs on a btrfs volume on one of the NVMe (cache) disks, so I am completely (Synology) unsupported as is.

Corrections are more than welcome so please feel free to share your own thoughts :wink:


You have the point in some cases… But let’s see for my case: boot time, resources, used RAM … are so far uninportant to me - i never reboot my machine (unless really necesarry), i have 20GB of RAM on my DS920+ and no USB sticks so far. I made my TLS/SSL certificates through Synology DSM’s reverse proxy, which is as simple as it can get. Machine is fast enough, since i only use my Syno for file backups. I already have btfrs file system. So, only down side is (and i already thought of that!) samba only file access. So if HA crashes i have no file access for possible data copying/saving. For this purpose i copy HA snapshots to my local HDD occasionally.

Docker version is still an ancient 18.09.0-519 in Syno DSM, so until this will be solved (if ever, either by Synology or by some third party docker updater) i’ll stick with VM. I like my HA to be supervised.

EDIT: i just found some info… supposely Docker version will be v20.xx in DSM 7.0. Can anyone confirm that?

1 Like

Hello, I have a question, so if I update to the latest version of DSM, will the virtual machine not recognize my connected USB devices? Zigbee, USB Bluetooth …

@Protoncek; It is even better then that, Docker 20.x is available in DMS6 at this very moment…

The latest release of DSM6.x is fine. The upcoming DMS7 is not.

The DSM7 release notes contain a statement that USB support for dongles will be absent. Only USB storage devices will work. I think you should definitely not install DSM7 until this is fixed.


@PatrickEhf :Hm… where? In my DSM under packages there’s only old version…
Do you have some extra community link?

See Docker - Add-on pakketten | Synology Incorporated. I have already installed it on my DS920+. I’m sure you will get it soon.