Installation options, clarification required

hassio
Tags: #<Tag:0x00007f2043fed8b8>

#1

Hi, I am totally new to homeassistant and spent some time trying to install. I need help to resolve much confusion between installation options. I have seen may attempts to clarify, but I am still not totally clear so any help would be appreciated.

Attempt 1. Install on local OS using pip works fine (sudo pip3 install homeassistant), I can get the UI on port 8123 and can configure dashboard, all good, but there are no addons as shown in the hass dot io install option.

I read that it needed to be a hassio home assistant docker image for the add-on feature.

My hardware is aarch64, docker is version 18.06.1-ce, and I followed the installation instructions to install corresponding docker image for aarch64 as follows;

wget “https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install

chmod 701 hassio_install

./hassio_install -m aarch64

then I run portainer as follows

sudo docker run -d -p 9000:9000 -v /var/run/docker.sock:/var/run/docker.sock -v portainer_data:/data portainer/portainer

I see three docker containers
hassio-supervisor
homeassistant
portainer

homeassistant is not running, when I start it, it stops after a few seconds with an error relating to incompatible container for aarch64, is that true

Now my confusion comes from hassio, is this the hypervisor or a container that I need to ssh into, should there be a hassio container that contains home assistant that is not there, what is difference between hass dot io and hassio and home assistant on hassio vs hassio-supervisor and home assistant containers,

This is what I found, please confirm or clarify,


IF you installed home assistant on Docker, you you are not running hassio.
If you are not running hassio, you will not have hassio menu or add-ons
You cannot “install” hassio on top of home assistant, it is its own instance of home assistant.
You can replicate everything that you can get in hassio with just normal docker containers. You don’t NEED hassio.
Hassio is like resin dot io, now balena
hass dot io is home assistant on hassio as a combined package
hass dot io is typically installed via a container
hassio_supervisor is installed first
hass dot io homeassistant container is then installed
but on aarch64, the container does not run due to aarch64 compatibility issues
can install homeassistant via pip3 and will run on local OS, no docker
but cant run addons in local os because add-ons are docker images too.
docker is like virtual hypervisor, but docker re-uses OS components
that is why docker images need to be compiled for specific architectures


Where does that leave me with my aarch64 docker install, is it possible and if so, how should i do it so that the container runs.

Apologies for the long message, but hope this explains the problem.

Regards, H


#2

What is your hardware?

You can run hassio in Docker, but if you are running just the homeassistant docker image, no you are not running hassio.

Correct

Correct

yep

HassOS is like resin.io. HassOS is the underlying OS if you run the preconfigured IMAGE, and not just straight docker

It’s a pair of docker containers. Home Assistant and a Supervisor. The 2 work in conjunction with each other.

hassio ONLY runs in docker, whether thats on hassos or on your own linux distro.

yes

what are you calling aarch64?

True

No, it’s not a hypervisor. It is just containerization of the application.

I would first verify your hardware is indeed aarch64, because according to the system it isn’t. Are you sure it isnt x86_64?


#3

Forget HASSIO, forget Arch64 for now. Just try the regular docker container first, homeassistant/home-assistant. Make sure you follow the instructions, especially net=host. Here is the command I used:

docker run -d
–name=“hass”
-v /home/wuench/hass:/config
-v /etc/localtime:/etc/localtime:ro
–net=host
–restart unless-stopped
–user $(id -u):$(id -g)
homeassistant/home-assistant

If the log complains about the type then investigate alternate container versions.


#4

Why? Because it’s not your choice?

It seems to me the OP has most probably installed the wrong image for his hardware…


#5

Thanks all for the super quick replies. I finally got it working now by starting over and deleting everything first. Not sure if that fixed it or we just used the right commands this time.

This was my solution:

pull container for aarch64

docker pull homeassistant/aarch64-homeassistant

run docker image

docker run -d –name=“hass” -v /my/path/to:/config -v /etc/localtime:/etc/localtime:aest –net=host –restart unless-stopped –user myusername homeassistant/aarch64-homeassistant

These commands resulted in aarch64 supervisor and homeassistant both running without errors, and login at localhost:8123 worked.

I now have access to add-ons and all the other great features.

When I used the installer script with aarch64 option, it did not work this time either. Does anyone know what the difference is between the installer script and manually running these two commands.

Thanks for your help, regards, H


#7

Hi,

I now have repeatable procedures for installing homeassistant via pip, docker and hassio. All options will produce a working homeassistant installation but I am unable to get addons to install in the hassio version. All addons are marked as “Not Available”.

The log says “[hassio.arch] Can’t detect underlay machine type!” which was also reported by others as the reason for addons being “Not Available”.

In the hassio code block relating to this error

    # Evaluate current CPU/Platform
    if not self.sys_machine or self.sys_machine not in arch_data:
        _LOGGER.warning("Can't detect underlay machine type!")
        self._default_arch = self.sys_supervisor.arch
        self._supported_arch.append(self.default)
        return

And in arch_data (json) it lists a few hardware platforms using aarch64 but the platform I am using is not listed. My platform is the NVidia Jetson TX1 which is aarch64.

There are a number of other hardwares using aarch64, do you apply the same image for all of them and hope for the best, or is there a specific aarch64 image for each hardware type.

In Portainer there is an option to add a label to specify io.hass.machine where I can add a “value” but I dont know what value it needs to be.

Can anyone advise me on how to get addons available in hassio on this platform.

My install procedure is as follows:

wget https://raw.githubusercontent.com/home-assistant/hassio-build/master/install/hassio_install

./hassio_install -m aarch64

(previous confusion resolved now and normal install procedure does what its meant to.)

Regards, H


#8

I had the same issue with my Banana Pi, what I did was to look at the json for a machine ID that uses my same arch (in my case armhf) and ran the installer with -m MACHINEID (in my case raspberrypi).
Everything seems fine now.

Good luck!