Installation Stuck: "link is not ready" / "power save enabled"

I’m trying to install Hassio in a new, unused 32GB SD card.

On my Mac, I used balenaEtcher to flash “hassos_rpi3-3.13.img” on my SD card. When it finished, I got an alert on my Mac saying “the disk you inserted was not readable by this computer”. I thought it was just an issue with the Mac and assumed the SD card will be able to run on my Raspberry Pi 3.

After inserting the SD to the RPi and plugging it to the electricity, it seems like the installation is trying to start, but it gets stuck with the following message in the terminal window, even after several hours:

brcmfmac: brcmg_cfg80211_set_power_mgmt: power save disabled
IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready

I did not setup the WiFi because my Mac doesn’t recognize the RPi after flashing the Hassio image.
Worth mentioning that I also tried formatting the SD card to FAT through Mac’s Disk Utility, but same result.

What do I need to do in order to properly install Hassio in this situation?

Hi did you manage to sort this out?

I have the same problem, I thought it was a wifi problem so I got an ethernet cable but I still have the same problem

I only have the power save enabled error not the Ipv6 issue

I’m having exactly the same issue. Connected via ethernet cable. Any resolution found? How did you fix it if you did?

I eventually managed to have it fixed by creating a folder named “network” in the root of the USB stick, as the official guide explains…

I fixed also, apparently it’s expected behaviour.
But the local home assistant site wasn’t working.

Needed to go to the general one: http://homeassistant:8123/ and that worked.