Installation very slow after reinstalling homeassistant and venv

I tried to update my installation by renaming the working homeassistant venv and make a new one:

pip install virtualenv
cd ~/
python3 -m venv homeassistant
source homeassistant/bin/activate
pip3 install homeassistant

I made a backup so I could easily go back, but I need to know why it failed.

The new installation was very slow and PyNaCl was missing for the Mobile App component. The configuration check took a long time, restart failed.

What could have gone wrong? Did I miss some dependencies? Shouldn’t home assistant install all components?

What version of Python were you using for that? It should have been 3.9.

3.9.10 was installed on the Mac.

Then, possible reasons could include that it’s compiling modules. The log file should contain some hints, but checking the process list will give you other information.

This stays for a long time.
Wrapping up startup, not everything will be available until it is finished.

Then I get this when checking the config:
Integration error: default_config - Requirements for mobile_app not found: ['PyNaCl==1.4.0'].

Installed is version 1.5.0, if I downgrade it, it works and is much quicker.
pip install PyNaCl==1.4.0

So this is a bug in homeassistant installation 2022.3.3?

What custom components are you using? One of them is specifying PyNaCL 1.5.0 - HA requires 1.4.0.

That makes sense. How can I find out what custom_components install?

It was config-editor. I deleted it.

Thanks for your help

I have this error again. How can I find the component making the issue?
Must be another one as well.

Check the manifest.json for all your custom components, then open an issue with the developer.

There are none under requirement nor dependencies.

I had one, but I removed it.

How do you uninstall a custom_component manually? Just removing the folder or is it more? Where are their setting saved?

Btw. is it safe to remove ~/.homeassistant/.storage/HACS I don’t have it anymore (I also just deleted the folder in custom components).

To remove a custom component:

  1. Remove the integration (through the UI or YAML as appropriate)
  2. Restart HA
  3. Delete the folder

Yes, you can remove that file.

Let’s say, I didn’t do the first step. :neutral_face:

How can I fix that?

Well, if it’s YAML then you can just remove the YAML and go.

if it’s UI setup though, you’ll need to reinstall the component.

I tried out a lot in the beginning. Where can I find what was/is installed?

Check your log file for errors, see what it’s complaining about - if anything.

There is nothing showing up.

If there’s no errors or warnings then you have nothing to worry about.