Installed Homeassistant in a Docker Container

I Have installed Homeassistant in a Docker Container and ther i have several Topics.

First iam missing the Addons Tab. Why? How can i make it Visible?

And Because i have no Addons i have no Terminal? is there any other way to get this?

You only get addons with HAOS, not with HA in a container.

1 Like

What’s your container running on? You can attach a terminal to the container via CLI or via e.g. Portainer interface.

I have HA in a container administered by Portainer running on my Synology NAS. If I need to, I can attach a console within the Portainer interface:


…but I do most of my admin using a ssh shell into the NAS (the container host) and then editing the files in the persistent volume that the container uses as /config.

What Chris said. There is no add-on tab for your installation type.

And by the way, most (if not all) add-ons are actually docker containers under the hood. So if you want/need some of those, you seem to know what you are doing and could manage your own containers.

1 Like

Totally this. I run Influx, Grafana, Mosquitto and a few other things as separate containers that are available as add-ons. I actually prefer it this way, rather than building a huge monolithic HA setup. If something goes wrong with Mosquitto, I can work on that separately.


+1 for this. I run the following docker containers on an x86 debian host.

  • Home Assistant
  • MQTT
  • Music Assistant
  • Frigate
  • Wyoming (open wake word, piper, whisper)
  • esphome
  • jellyfin
  • influxdb
  • grafana