Installing Core, pip3 can't find latest homeassistant version

I’m following the instructions to install Home Assistant Core. I reached the point where I activate the python virtual environment, install wheel, then attempt to install homeassistant using pip3. But the latest version, which is indicated in the tutorial as being 2024.4.3, is not found. This is the error I get (I truncated it):

(homeassistant) homeassistant@thinkcentre:/srv/homeassistant$ pip3 install homeassistant==2024.4.3
ERROR: Could not find a version that satisfies the requirement homeassistant==2024.4.0 (from versions: 0.7.0rc1, 0.7.0,, 0.7.1, 0.7.2, 0.7.3, 0.7.4, 0.7.5, 0.7.6, 0.7.7, 0.8.0, 0.9.0, 0.9.1, 0.10.0,
... really long sorted list of versions...
2023.7.0b1, 2023.7.0b2, 2023.7.0b3, 2023.7.0b4, 2023.7.0b5, 2023.7.0b6, 2023.7.0, 2023.7.1, 2023.7.2, 2023.7.3)
ERROR: No matching distribution found for homeassistant==2024.4.3

I have python3.10 installed:

(homeassistant) homeassistant@thinkcentre:/srv/homeassistant$ python3 --version
Python 3.10.12

And I’m trying to install in Ubuntu 22.04 x64:

(homeassistant) homeassistant@thinkcentre:/srv/homeassistant$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 22.04.4 LTS
Release:	22.04
Codename:	jammy

I was able to update all my packages with apt, and to install all the dependencies indicated in the instructions, except for libtiff6, which is only available in Ubuntu 23.xx and above. Instead, I installed libtiff5, which was available, but I do not know if that could be the root cause of the problem.

What could be causing the list of available homeassistant versions in pip3 to only show up to 2023.7.3? Why can’t install 2024.4.3? How can I make it available?

Current HA needs a Python 3.12 installed.

First update Python to 3.12

Okay, thanks for letting me know and for taking the time to answer my question.

Nowhere in the tutorial does it say that I need 3.12 specifically. The dependency list only indicates the python3 package.

I am just noticing a pattern of similar questions like mine and the answer ends up being “make sure you have the minimum python3 required version installed”. Maybe the dependency list should explicitly indicate python3.XX instead of just python3 to ensure these kinds of questions get reduced to the minimum.

Read over it ?


I did, apologies. Thanks.