Installing (deprecated) hassio on Ubuntu 18.04

Thanks for the tip. Something else I’ve to dive into… do you have by any chance a tutorial or info page you can share?

The Proxmox site will inform you on the installation of Proxmox.
To install HA you can check the topic below, but read it carefully. The HassOS version used there is still in beta -> Supervised Install on Proxmox

Cheers, I’ll try first this tutorial:

which just stays with ubuntu running virtualbox to keep it easy, otherwise i’ll try with proxmox.

I need to replicate the install I already have using this method before looking for a new alternative.
I am trying to get the script to install and have the same error. I am trying in vain to do the workaround but have failed. I used wget to copy the file and then edited the “then” command but I can’t then get the script to run locally. Please can you point me in the right direction?

I support your advice.

Adjusting the installer script is like an entrance test. If you fail it then you probably need to study some more or choose something else.

In the recent blog post, I was quite surprised by the number of people asking what they had installed and were they affected by the deprecation. I wouldn’t think it was possible for someone to not know what they installed, but I was proven wrong.

There is a PR to add additional info to the ‘Info’ page to show what OS and installation type a user has. It would seem many will still not know, but at least they can be directed to go and check that page.

“If your info page says X, Y and Z, this will/will not effect you”

Use this URL


is this working fine?

Worked great for me yesterday on OMV/Debian.


This also work under UBUTU SERVER installed on NUC

I got it working
curl -sL "" -o
[remove the following]
if [ "$x" != "not supported" ] then echo "OK, bye!" exit 1 fi

save and close

cat | bash -s -- -m raspberrypi4

Granted, I’m a noob, but installing on buster (so I can SSD boot on my pi4) has become a royal pain

Can you post the full script please
I try this curl -sL “” | bash -s
This is correct???

user mine
curl -sL “” | bash -s

it works and in debian too

I’ve spent the last few days trying to migrate Home Assistant over the an Intel i7 NUC. I’m new to HA and discovered soon after installing that my Rako lighting was going to be easier to control if HA was not on a Raspberry Pi. I have been following these instructions -

The install was not working and I have just found this thread which seems to explain why.

What is currently the easiest way to get HASS.IO onto a NUC? Should i just wait for the to be fixed?

I’m running now HASS.IO with Proxmox. It’s a virtualization software and it is running great and easy to setup.

I’ve followed this tutorial:

1 Like

Except it’s no longer called hassio. Its name was changed to Home Assistant OS in June. All of the official documentation has been updated. Only third-party tutorials, created before the name change, still use the deprecated name (and users who haven’t kept up to date with Home Assistant’s evolution since June).

Yes, I know.

Hassio is just the term that is still being used by many people.

Your post is not usefull nor meaningfull.

It’s the wrong term, no longer used by the development team, nor anywhere in the official documentation, nor by users who are aware of the change made nearly a half-year ago. If you know that, then please use the correct term.

The only people who continue to use the deprecated term are the unaware (or the obstinate).

It’s neither useful or meaningful to employ it other than to confuse new users who won’t find it used anywhere in the documentation.


It’s also unhelpful to use the incorrect naming convention.


HASSIO on Proxmox has finally worked for me having tried and failed with Ubuntu and even directly installing HASSIO on the NUC.

Proxmox method was pretty straight forward, even for a newbie.