Installing HA on KVM running on Fedora Workstation 36

I’m trying out KVM as an alternative to VirtualBox and run into problems. Following the installation guide on Linux - Home Assistant, section KVM it states the following:

  1. Create a new virtual machine in virt-manager | OK
  2. Select “Import existing disk image”, provide the path to the QCOW2 image above | OK
  3. Choose “Generic Default” for the operating system | There’s no “Generic Default” but Generic Linux 2018 and 2020; I chose 'Generic Linux 2020’
  4. Check the box for “Customize configuration before install” | OK
  5. Select your bridge under “Network Selection” | Selecting bridge opens up an input field ‘device’; I have no idea what to enter here; what device do I add here and how do I find the device on my system
  6. Under customization select “Overview” → “Firmware” → “UEFI x86_64: …” | There are about 6-7 options that start with x86_64. Which one do I need to choose?
  7. Click “Add Hardware” (bottom left), and select “Channel”
  8. Select device type: “unix”
  9. Select name: “org.qemu.guest_agent.0”
  10. Finally select “Begin Instalation” (upper left corner)

It could be that the instructions are for an Ubuntu system, which is what I use, but I’m not positive about that. Anyway, I’ll try to help…

  • Generic - I only had the one choice Generic default, but I would think Generic Linux 2020 would work.
  • Network Selection - It is a general practice to create a kernel bridge on your host that the VM will use. A name like br0 is commonly the name given for this kernel bridge. This bridge should show up in your network Selection list. There may be a second part to this (I’m doing this from memory), and that is to select a virtual Ethernet NIC device you want the VM to use. In my case virtual manage calls this a “Device Model”, and from my input list, I picked e1000.
  • Customization UEFI x86_64:… - I seem to recall I just had one option. What I have currently points to /usr/share/OVMF/OVMF_CODE.fd.
1 Like

Thanks for getting back. Did some more research ( and the part that seems to be missing in my case (I want to bind the network to the physical Ethernet interface as opposed to using NAT) is the creation of a bridge. That also ties in with what you said in your response to network selection; i.e.

It is a general practice to create a kernel bridge on your host that the VM will use

I’ll try to create that bridge to verify this works

Just an update that everything works as expected after I have created the bridge per the above mentioned URL… Thanks for that input