Installing HA Supervised on Rpi4-64 8gb | I need to wait? ...or is something wrong

Noob here. New Pi with a fresh 32-bit Raspberry Pi OS. Updated, and installed network manager and apparmor.

Installed Docker and Andreas Spiess’s IOTstack, including Portainer-ce ( Opened Portainer at port 9002 and Grafana, Plex, etc. are all running and addressable from the browser at their respective ports.

Next, instead of proceeding with Andreas’ hassio installation from the IOTstack menu, I installed HA this way:

curl -Lo
bash --machine raspberrypi4-64 -d /usr/share/hassio

By installing HA Supervised this way, I had hoped the result would be different from my previous attempts to install hassio from the IOTstack menu; however, I am facing the same issue as on previous installs in the past 24 hours (and I suspect I installed the exact same package, merely circumventing the IOTstack menu): I open Portainer and the homeassistant container is stopped. The terminal installation commands were all successful, with the usual green font in the terminal declaring at the end of the install process that my HA would be accessible from port 8123, and that it would take a while to install. And I’ve waited over an hour.

If I go to 8123 the page cannot be displayed. I just tried starting homeassistant in Portainer and it won’t start. Exit code 1.


Another thing. I eventually shut down, after waiting nearly two hours for the problem to resolve on its own. I shut down from the rpi menu, then when the power was off I disconnected the ethernet cable and the power. I plugged in the power and waited for the pi to boot. When it arrived at the desktop, there were no available network connections and “dhcpcd not running”. This has been the result of all of my install attempts. It always knocks out my wlan0 connection. I started dhcpcd via the terminal last time I faced this issue, but I don’t know how to turn on wlan0 and get my wifi networks back. So, I started from scratch with a new 32-bit OS and arrived here. I’ve been through this at least five times this weekend. It’s time to post to the forum and ask for help.

use below guide if must install supervised (eg want SSD support). However, don’t think 32 bit OS will use all your ram.

Since you need a 64bit OS, Probably easier to just use 64bit hassio image for Pi4. Running hassio is way easier. I don’t think you can install 64 bit docker image on 32 bit OS (as you tried).

Thank you for the reply. I have installed docker via the IOTstack menu (because I know this method has worked thus far) and thereafter I have installed Home Assistant via the link you provided, and I just received a login screen at 8123 for the first time. I greatly appreciate your having shared the link.

–oh, and I started over with the 64-bit Raspberry OS. Thanks for the heads up.