Installing HA v0.41.0 in virtualenvt not create hass file for autostart using systemd


Recently i installed HA v0.41.0, in virtualenv in my raspberry pi and checked that works using the virtualenv:

$ source /srv/homeassistant/homeassistant_0_41_0/bin/activate
(homeassistant_0_41_0)$ hass

After check that in this method worked, then i decided to follow the autostart using systemd:

But didn’t worked. Then i used the commend:

$ sudo systemctl status home-assistant@[your user]

To see log of th autostarting and there appear a message that told me that in the route /srv/homeassistant/homeassistant_0_41_0/bin/ no exists the file hass, once i go to this route, i see that this file not exists and i dunno why HA didn’t downloaded/generated once that i installed from the beginning, so without this file i can’t create the autostart option.

Someone knows why this file was not created/downloaded by HA when i install? i must do something to generate it?

thanks to everyone

You need to specify in the systemd file where the hass program is installed. To find this out try

homeassistant@raspberrypi:~ $ source /srv/homeassistant/bin/activate
(homeassistant) homeassistant@raspberrypi:~ $ which hass
(homeassistant) homeassistant@raspberrypi:~ $

The output of which hass is what you need to add to the exec line of the .service file

This is assuming, of course, that you can still run hass manually :slight_smile:

Hello @gpbenton,

After using your command, i found which is the hass pwd. After i changed in my austostart file service and then worked!

So thanks a lot for this new knowledge!

hi @gpbenton where do I put it in the exec line of the .service file?

I’m not sure what you mean. The format is shown in the autostart guide