Installing HAOS in a VM on TrueNAS SCALE

Hi @HariGuns, I’m sure you’ve tried a few times, but your screenshot has mixed port numbers. 1823 should be (as you mentioned) 8123 - Maybe you did not notice and have been trying the wrong port?

Have you tried viewing the Observer URL

Are you able to ping from the Home Assistant display?


I’m still trying to figure out the best way to help people troubleshoot this VM on SCALE - Sorry, I don’t have more to offer at the moment.

Hi @troy

So you were right about the wrong port! :sweat_smile: I’m going to delete my above post out of sheer embarrassment now! Thank you for even replying to me!

Thank you for the tip on ping as well… Helped me figure some other things out.

1 Like

I have another question. I have Komga and Plex running on the same Truenas server as my now functioning HAOS VM. Before I was able to add the IP address to my Cloudflare plugin and access them outside of my home network on a domain. How ever now I am still able to access Home Assistant but Plex and Komga aren’t working.

And when I try to ping the ip address its says unreachable

Anything I can try to fix this?

so in playing around, I figured out its something to do with the VM not being able to access the same IP Address as the server its loading. I’m not entirely sure how to proceed from here. I’ll give the other Forums a try as well thank you @troy

1 Like

Did you setup a bridge on Truenas scale Network settings?


Hey there, I’m completely new to HomeAssistant and TrueNas. I have followed the instructions and also tried doing everything as root User with sudo in front of the commands. In the end I get the following error:

qemu-img: /dev/zvol/Pool/homeassistant: error while converting raw: Cannot grow device files

What can I do about this? What am I doing wrong?

Off topic but maybe answering these questions can make my life easier.

I wanted to start with a Synology DS220+ but figured it wouldn’t be powerful enough for a Plex Server and HomeAssistant at the same time. My Plex Server will be used primarily for Photos and Videos. Movies are not a requirement for us.

HomeAssistant won’t be too crowded as we’re living in an Appartment and mostly have lights, temperature sensors, thermostats, door/windows sensors.

As of Data storage, I’m using Apple Devices exclusive, if that information is of any importance.

Do you guys recon the Synology would be enough when upgrading the RAM to 6GB?

Thanks in advance

Hi @volly92

I’ve seen this happen when the ZVOL is not sized correctly.

Here is a ZVOL I created using size 64 GiB

  • Notice the Volume Size is 64 GiB

Here is another ZVOL I created using size 64 but I forgot to add GiB

  • Notice this time, the Volume Size is only 16 KiB

Please confirm your ZVOL size.

1 Like

Thanks a lot. Looks like that was the problem. Do you have any tips regarding my other question?

1 Like

I don’t have experience with anything Synology but 6 GB of RAM sounds light for something running multiple services, I could be wrong though. I’m guessing you’ll get better advice starting a separate thread with your other questions. Or ask on Home Assistant Discord, if you’re a member.

I don’t mean to send you away, just that you’ll get more eyes on your other questions in their own thread

No worries. I think a different thread will be better as well.
I have HomeAssistant up an running on the VM now. I have tried passing through the HA SkyConnect adapter through USB Pass Through but it won’t show in HA

I think @Chris2fourlaw got thier SkyConnect working. I’m not sure if it also requires a module_blacklist similar to the ConBee II.

Black listing a module is done using the Scale CLI - not directly in the shell. You can start the Scale CLI from the shell using sudo cli - then you can enter the following

system advanced update kernel_extra_options="module_blacklist=cp210x"
1 Like

Thanks. That worked as well.

1 Like

Well I guess I have to take that back. It shows the stick in HA and it looks like its using for devices. But it won’t find the Zigbee Device. I had the same Device working when HA was installed on my RPi 4 with the SkyConnect Adapter.

Did your stick work by just blacklisting the module?
I have done exactly that and the Stick is showing up in HA. But it is not able to find any devices. I have tried it with HA on RPi just to make sure the stick and Device work fine.

Would be awesome to get some help here :slight_smile:

where i’ve to type this command?

If you go back a few posts you will find

Unfortunately this was not enough for the ConBee II on my system. I’ve not had time to further troubleshoot because I got busy with work.

I’m hoping for more time this weekend.

Ok, i didn’t see your post before :slight_smile:
If you’ll have any new ideas please share it.

1 Like

Please still try the command to see if works on your system and kindly report back.

Also can say what version of SCALE you are using and what controller type you are trying for the ConBee II? It seems like USB passthrough is hit or miss but we don’t have enough information narrow the issue.

My system version is TrueNAS-SCALE-22.12.1 and i try qume-xhci and nec-xhci controller and both didn’t work and of corse i typed the command into cli shell

1 Like

I’ve spent a few hours trying to get the ConBee II working to no avail - At this point, I don’t think the issue is TrueNAS-related but something either with the ConBee II itself or a bug in KVM.

Here’s some reference to this issue reported on both Ubuntu and Debian host here and here

I also installed virt-manager with QEMU/KVM on my desktop (running Arch Linux), created a VM with HAOS, and tried adding the ConBee II - I’m getting the same error as on Scale.

Also of note - I dug up my old NORTEK HUSBZB-1 to test as well. I’m happy to say it shows up / works in my HAOS VM as expected (no module blacklist required)

EDIT: I just pre-ordered (3rd batch) a sky connect to test as well.

EDIT 2: I tried HAOS in VirtualBox on my desktop and the ConBee II is working there. So this seems to be something with KVM. But only with certain devices?!