Installing on Intel NUC?

being using HA for almost a year and was excited to play with and since I had a decommissioned NUC thought I’d give it a go (as a dev box for now).
I downloaded the NUC image and used etcher to put onto a USB drive, my question is does the image loader expect to install on an internal drive?
I was hoping to install and run off the USB drive… After many attempts I had no luck, when I start up the NUC with the image the screen comes up with the HA logo and sits there…

Is it possible to write the image directly to an SSD?

I’ve got an old spare NUC I’d like to get this going on but not really clear how to use the image for NUC.

I guess you could put the image directly onto an ssd but I’m not sure how its supposed to work… I would have thought putting the image on a USB drive and booting of the USB drive would have worked but it appears not.
Hoping that someone here that built the image for the NUC can shed some light :slight_smile:
To be honest if the image can run of a USB drive on a NUC then you have have a pretty darn powerful and reliable Home Assitant build- holy grail stuff.

I’ll have a go at a direct HDD install next weekend if I have time.

I tried installing it on a debian machine a while back and got it going so that’s always an option for USB. I did have trouble trying to install debian on the NUC so this might be the issue. I have an N2820 celeron model.

I have this problem too.


How to install on an Intel nuc?

Imaging direct to SSD half worked, same results as @Aussybob with USB.

If you tap a key on the keyboard while the hass logo is showing it shows a failure in resinos but I didn’t write it down and on the second boot the grub loader fails. I have a feeling my NUC has a bios that is incompatible as I’ve had trouble loading 64 bit Linux on it before.

I did not get this to work on my DC3217IYE either, also did a bios update but still nothing.
So I chose a completely new approach with Rancher, check out my topic:

1 Like

BIOS isn’t touched by the hard drive. If you flashed the image on the ssd, there is no way it touched the BIOS.

PS, you can use a NUC if you just install a normal Linux distro and Docker. There is no need for HASSIO, Home Assistant is provided as a normal Docker container.

Yep…was trying to find a quick way and use hasio

Hassio works on NUC. Pick the NUC image, flash it to USB. Plug into your NUC, boot from USB, and HASSio will copy itself to the internal SSD/HD and then reboot into HASSio to complete setup. After it’s copied to HD, you can remove the USB, it’s not needed anymore.

Thanks, I will try it again, I also a ordered a Pi3 to see if there is a big difference. I miss understood the instructions while installing the first time, I booted the image and didn’t tell me that it was completed it just powered off and i thought the installed failed. I am guessing that it installed on the SSD. I will test my logic today.

Yes that’s right - after it turns the NUC off, remove the USB stick and turn the NUC on. HASSio will then complete its setup process. :slight_smile:

Is there a benefit of HASSio install vs linux install?

With HASSio you get the addons that are community supported. With Linux you have more control but need to install everything separately. Also if you intend to use your NUC for more than just Home assistant (eg Plex) then you’ll need to use Linux rather than Hassio

You can quite easily install Linux & docker then deploy hassio. Best of both worlds.

Can you please give instructions on how to, or a link?

I wish to have HASSIO on NUC, but use the he NUC also concurrently for other tasks (Kodi, Netflix, Plex server basically media center).

Now I have the NUC with Ubuntu 16 and use as media center, and zoneminder server

Official Instructions here:

When they write “requirements”

How to add all of the above on an existing Ubuntu installation (possible?)

Simply use Docker on top of your existing Ubuntu installation. If you’re interested, benefits to use Docker have been discussed here.