Installing onto Ondroid XU4 with eMMC

Hi … First off I’m not a coder or programmer a just bloke with enough knowledge to mess things up so bear with me, please :wink:

I’ve been running HA on an old SBC for a few months and was getting frustrated with some lag/response time issues with the board.

I purchased an Odroid XU4 with a 32Gb eMMC with the Odroid eMMC reader.

I can run the install from an SD card but can get zip when I try to install and run from the eMMC.

I have tried resetting the eMMC using the instructions from Odroid and can get Android working from the eMMC.

Feels like I’m missing something pretty fundamental in how I am flashing the image on to the eMMC. Any guidance is very welcome.



I have the same hardware, but run it in docker under ubuntu. You should be able to just burn the hassos image onto the emmc using etcher. Just as you would with an sd card.

Yes I was thinking that. I’m using the official ODroid eMMC reader and the latest balenaEtcher but when I power on all I get it the solid blue light (no ‘heartbeat’), no output to screen and no IP.

Should I be placing the image into a specific folder on the eMMC or just letting it image the whole card.

I’m thinking that it’s something to do with the boot area for the eMMC??? Am I wiping that out when I write the image?

Etcher takes the image and writes the unpacked filesystem onto the emmc. Everything you need to boot is on it. Just follow the instructions, especially the static IP setup section.

Noted Thanks Will retry.

(FYI - For the IP I have the ODroid’s registered on my Mikrotik RouterOS as a static IP)

Did that work? Just so I know next time I try a complete re-install…

No Even with the USB connected all I get is the steady red and blue LED. No boot.

have o tried that mate? eMMC Recovery Tool for XU3/XU4 - ODROID

Yep but no luck.

I can create Ubuntu, Ambrian etc images and boot, load and run so the board and memory is definitely OK

It seems that just won’t load from a eMMC? Unless there’s any other input I guess I’ll have to do as @nanobra1n has done and run thru Ubuntu and Docker

Hi John! Did you find a solution in the end? Have exactly the same issue with XU4.

Yes … very straightforward. Make sure your have ‘reset’ the eMMC to the Android then push through with the Armbrian install, update with the addons included, then install with the code line shown.

I’ve run it all a few times now and very happy with it all so far/ run very fast and very reliable compared to SD

1 Like

Looks like it’s time to revisit this topic due to latest blog post from Home Assistant.
I’ve found this issue on GitHub, but looks like it’s also abandoned.
Have anybody fixed this somehow?

I’ve also find this on github.
Have anybody succeeded with this recipe?

@m0thman Hi mate … I’m now running 3 systems with Ambrian Buster with the HA in Docker. So not using the XU4 image. I’m trying to read that post but my eyes are glazing over :slight_smile: … are they saying that running HA in a Linux Docker wont work in the future?

I believe they are saying that Supervisor on Linux will be deprecated in future. So you’ll be able to run Home Assistant Core in docker in future, but with no supervisor.
If you’ve installed HA with armbian-config Softy tool, then you are running it with Supervisor.