Installing Home Assistant OS on a Mini-PC

Try the method, I mentioned, i guess?

1 Like

You know you’re not being helpful, right?
I have of course searched… (and posted in another thread based on that search)
I’m looking for help, not a lesson in dealing with unconstructive comments

Sheesh - nice welcome new users get around here

I’m sorry, but that was not ment that way. The advice to search was directed to a off topic post. If I have to say something on topic, I write it out, as you had seen.
But the discussion about well or not run on Win10 is not really on topic and I do not know much about that. I just remember, that there is a lot info about it somewhere. So I’ve said that.
Sorry, but I’m no one’s secretary to search the answers for them.

I’m trying to advise you on yours system, I think, I do that very well.
Well, it is actually quiet discouraging for me, getting this kind of reactions after I’m spending my time to help others…

Never mind, I still em focused on your original question and will help with that. I will from now on ignore the Win 10 part, if that suits better.

And try the method I’ve mentioned, if that’s, what annoys you, then - i just refer to already written answer back in the topic, do you want me to copy paste it or what? I don’t understand…

If you do have more questions about that method, fire them. But please, don’t shoot at me, when I’m trying to help. Just my 2 cents…

1 Like

Okay, now we are off topic…
I’m not asking about Windows 10… “I’ve put the NUC image on a flash drive and booted on the system” If anything your answer is off topic! I want to install Home Assistant OS on a Mini-PC - your answer was around installing Home Assistant in a docker container… not what I want. Then telling me to go search and then referring me to said answer in another post is not useful or welcoming to a struggling new user.

Anyway, back ON topic
Is anyone able to please help me get this installed on my machine…

I’ve put the NUC image on a flash drive and booted on the system but when it loads there is a menu there but i can’t see what it says! Seems to disappear off the screen leaving just the underscore

Eventually after pressing a bunch of buttons I get to the

Enter exit to get back to the menu
HassOS-boot:/

command prompt but then no idea what I’m supposed to do here because presuably I want to be installing something before i get here! I want to run it off the internal drive…

I’ve told you, how you can do it, one of the possible ways. You chose another one, that’s fine. It seems not to be working. So I remind you, that I’ve told you already about a different way to achieve your goal, which in my eyes WILL work. You even liked that answer back then. What the hell is wrong with that?

Sorry guy, but if this is your attitude towards helpers, I’m out to next topic, where help is appreciated…

The HAOS NUC image only works on a limited range of hardware. If you don’t have NUC or identical hardware to a NUC you should install debian 10 and home assistant supervised, just like @BebeMischa correctly advised.

This thread has gone a little dark, but if you do what we have now BOTH suggested you will have success. The howto is here Installing Home Assistant Supervised on Debian 10

I am a very minor contributor to that howto.

3 Likes

You can follow the official instructions HERE. This requires that you attach the drive you intend to use in the Mini PC to your Windows PC and flash it using Etcher.

Home Assistant OS also uses Docker, so if you don’t want to have Docker on you machine, the only choice you have is to install a Linux OS of your choice and install HA Core. Instructions on the same page I linked above.

You’re being a little combative for someone who is new, and, needs help.

I suggest you follow the Official instructions to install HA OS, or as Nick and BebeMischa have also suggested, follow the HA Supervised on Debian guide, unless you don’t want Docker, then install Core.

1 Like

HA OS 6 was released this weekend and now supports a good deal more x86-64 hardware than the NUC. So what you want to do may work now.

You will need the version 6 image, I am not sure which version you tried. The docs have been updated, Installation - Home Assistant

I am still a debian/supervised advocate, but you may be better placed to avoid debian now if you are sure that is the way you want to go.

1 Like

For what it’s worth, I installed the Home Assistant OS NUC image (2 days ago) on my Intel NUC8i3BEH and it’s been working fine so far. I updated to the new Home Assistant OS 6 (the NUC image has been renamed generic x86-64 in Home Assistant OS 6) and it’s still been working fine.

I did it by using BalenaEtcher on my MacBook to flash the NUC image from here onto my Samsung Evo Plus 970 M.2 nvme SSD. I did this by using an M.2 nvme SSD to USB-C adapter case (the specific adapter I used was made by this Chinese company called Ugreen), and connecting the SSD directly to my MacBook to flash the image.

After that, I took that SSD and installed it directly into my Intel NUC, disabled secure boot in my NUC BIOS, and Home Assistant could start up and was working.

1 Like

Which is exactly what I linked - following the official instructions.

Those official instructions miss a huge step on getting connected to the network…

1 Like

Do you mean plugging an Ethernet cable into your device?

I plugged an Ethernet cable into my Intel NUC and it connected to the network automatically. I used my router homepage to identify the NUC’s IP address. The default host name for it is “homeassistant”.

Jesus why is everyone around here a smart arse… Beginning to think that Paul Hibbert is right…

What about those of us without a wired connection?

If it’s wired only then yes, that step needs to be stated

1 Like

You didn’t mention the requirement to use WiFi in your OP, or any other post, so why would someone link that for you? You are getting upset with people offering help when you haven’t provided all the variables of your equipment or use case scenario.

It isn’t included in the instructions as it isn’t a recommended way to run HA.
These instructions should help you setup WiFi.

If thrusting your hips in the air in a sexual manner while angrily repeating something ad nauseam is something that you feel is more beneficial, then perhaps HA isn’t for you.

You aren’t helping yourself by being so adversarial. You come looking for help, people are trying to help you. Stop throwing mud.

3 Likes

If having it plugged in by ethernet “just works” as you imply and I I was asking how I connect to a network, then logic dictates that I must have been looking for WiFi. And for the record I did ask in a different thread specifically about WiFi (tho I wouldn’t be expecting you to look, just tackling your statement on “or any other post”)

The instructions don’t specify a recommendation either way as far as I can see…

Anyway thanks for the link, what if I don’t have a working ethernet connection (base assumption on that link)

I’m thinking both sides of this kerfuffle could tone down a bit. We who have been at this a while need to remember that, when you’re starting out, you often don’t even know what question to ask or how specifically to frame it. All you know is that you tried something and it didn’t work.
The new folks could do well to read through the “How to help us help you” article and remember to provide as much detail as possible about exactly what you were doing, at what point it failed, and what, if any messages you received when it did.
Patience, all around is vital. I’ve benefitted in so many ways from people who took the time to answer my questions in detail. I’ve also benefitted from following links and reading up on my own.

3 Likes

No, it doesn’t.

I am addressing this thread, not some other thread. I have no idea what else you posted somewhere else.

Or, try this.

After you have flashed the Home Assistant image to the drive, go to the Windows File Explorer. The drive should now be labeled haos-boot (or similar). Double click on it and then create a new folder named CONFIG. Then, inside that folder, create another folder and name it, network. Using Notepad, create a new file named my-network (no file extension) with the following:

[connection]
id=my-network
uuid=YOUR_UUID_NUMBER 
type=802-11-wireless

[802-11-wireless]
mode=infrastructure
ssid=YOUR_WIFI_NAME
#Uncomment below if your SSID is not broadcasted
#hidden=true

[802-11-wireless-security]
auth-alg=open
key-mgmt=wpa-psk
psk=YOUR_WIFI_PASSWORD

[ipv4]
method=auto

[ipv6]
addr-gen-mode=stable-privacy
method=auto

You can generate a UUID HERE

I don’t, and haven’t used the instructions listed, so can’t help any further.

I just see only in one last week the fourth topic, where some wise nose is stating against a newcomer, that maybe he is not capable enough to run HA, based on that one single question.

This annoys me realy very much, the sphere on the forums is touched by this behaviour.

So i will say it again, even expecting a rainshower of critics from the best coders on this planet, who knows everything:

Not everyone here is even smart as you. If people ask for help, tha last thing they expect is being told, that their are maybe not capable enough. Well, that way any learning is blocked, no any help is given, it’s just a smash in the face.

Please, realise, that we are all different, have different skills and need different methods to learn and find out, how things sticks together. Be kind to each other.

That part, Paul Hibbert is right. I’ve experienced this here also. And I’m actually a geek my whole life.

Thanks for listenning.
And now I’m seeking cover, because I know, the stones are going to fly against my head… :slight_smile: Well I don’t care. If I only helped one man to change his mind, my mission of this message is accomplished.

2 Likes

Thanks. Will give that a go, appreciate the help