Installing Home Assistant OS using Proxmox 8

Excellent. I have added those steps to the instructions.

1 Like

I have installed HA in Proxmox and its up right now but I am having issues with the homekit bridge app. I keep getting an “Accessory not found” on my phone. Has anyone been successfull on getting Homekit bridge working on Proxmox.
I think my issue is that I cannot seem to get Avahi to work properly on Proxmox.

trying ProxMox out on an old Acer Revo 3900 atom processor… proxmox installs normally. I followed the instructions to the letter but when hass vm boots it doesnt get an IP address, tried everything above you suggested to get the guest agent running, but results are always the same with no agent running/ no IP.

also hass vm console output has errors .

any suggestions ?

Is the CPU able to do virtualization? I’m not sure many, if any Atom processors do.

Do a google search to check the specs for the processor, and if it does support virtualization, make sure it is enabled in the bios.

I dont believe it does support cpu virtualisation extensions, but I also read that you can disable this in the Guest machine by switching off KVM hardware virtualisation.

1 Like

You may be better off running a Supervised install, instead of Proxmox on that machine.

Im running on a RPi3b at the moment, what I love about it is the simplicity in terms of upgrading and addons, i have Grafana, adguard, duck dns etc…

Running on HA supervised on Debian, will that mean i wont have access to the addon-store like in Hass.IO ?

Sure will.

Just as note, the name is no longer used - it was renamed some time ago. See here for the new naming structure.

No if you use supervised you will have the store as well. Best of all worlds.

This sounds worth doing. Thanks for your replies gents… lets see if i can breath some life into this 10 yr old atom :slight_smile:

One last question before I start building it, I’ve got a zwave USB dongle, will this just work out of the box or is there USB redirectors I have to install ? Sorry I will do some more research once I get home but thought I’d ask here forst

Passthrough of USB works out of the box. It’s listed in the guide.
Installed Proxmox just yesterday using this guide, thank you author, and my deconz zigbee stick worked perfectly.
Do note that you might run into issues restoring backup, see another thread regarding 502 bad gateway. I also had issues with my setup regarding duckdns, unifi running as HA addon and using a custom port.

I followed your Debian guide with my machine and it works flawlessly.

Anyone who has an old Atom 230 netbook lying around be advised - it works perfectly :smiley:

1 Like

Thanks for the awesome guide. Got everything going and I’m stuck on this step.

Under HOST NAME enter the IP of the Ubuntu machine, leave PORT NUMBER at 22, enter the username and password you created when installing the OS to your machine, and then select LOGIN. If you are prompted with a security window, select YES to continue.

2.2b) Navigate to /usr/share/hassio/homeassistant . This is the standard storage location for all user configuration, YAML and custom folders.

I don’t see the hassio folder; or am I missing something?

Thanks again. :+1:

Thank you Kanga and Whiskerz007.
All up and running very quickly and without any issues on a Dell 9020m.
No way that would have happened without the work the two of you have put into this guide and script.

1 Like

When using a HA VM, the config location is at /config, not /usr/share/hassio/homeassistant

Don’t have it in ’ / ’ either. Never mind, had to upgrade all my Tasmota devices so started with a fresh install of everything. Cheers again. :ok_hand:

You’re in the root of the Proxmox OS, not the HA VM. You need to install the SSH add-on from within HA, then you can connect to the VM with something like WinSCP.

1 Like

All good; sorted. Thanks.

Hi @kanga_who. I found this thread while looking for an alternative way to install my Home Assistant. Just learned about HA a few months ago and started testing it for implementation when we move in to our new apartment.
My Test HA is on a VirtualBox VM in a 10-year old Windows 10 laptop with a first gen Intel i5-520M, 4GB RAM and 640GB HDD. I also have another VirtualBox VM with Ubuntu 20.04.1 LTS Desktop in which I have Tuya Convert setup to Tasmotize devices. On Windows 10, I have installed Plex Media Server (using the same 640GB HDD as media storage for home videos and old TV shows downloaded using a torrent client also installed on Windows 10) and PlexConnect, which only works with Python 2.7.x ( I use PlexConnect for my Apple TV 3 to have access to my PMS.
The 640GB HDD failed recently so I have a 500GB SSD on the way. After reading this whole thread, I decided that I will install Proxmox instead of Windows 10 on the SSD.
Your guide is very detailed and I’m confident that I will be able to follow it successfully to get HA running. Since you are using Proxmox with multiple VMs for your HA, PMS, etc., my questions are more on using Proxmox for PMS and PlexConnect. I have very limited Linux knowledge so excuse any basic questions.

  1. Any reason why you are using Ubuntu 18.04 for your PMS? Can I use 20.04.1 LTS Desktop instead?
  2. Can I install PMS directly on Ubuntu without using Docker? Any downsides in doing this?
  3. I’ll be using the same SSD, where Proxmox is installed, as my media storage for PMS. How should I setup my media storage in the Ubuntu VM for PMS so that (a) I can copy videos to the media storage by attaching an external USB hard drive to the laptop and (b) I can install a torrent client in the Ubuntu VM to download and save old TV shows to the media storage?
  4. PlexConnect only works on Python 2. Does Ubuntu 20.04.1 only come with Python 3? If so, can I install Python 2?