Installing Home Assistant Supervised on a Raspberry Pi using Debian 12

I just have 2 sensors, so I can spot an update immediately

This os really nice, how have you implemented this ? Kindly share

Left one is a Github integration
Right one is a Supervisor host sensor

The images are just standard badges

Thank you :+1::+1:

Are there any sensors in Homeassistant that report the above three states as shown in screenshot ?

I had the same issue of lack of GPIO and 1WIRE with the debian12 , (in my opinion a step backwards), I managed to work around this an documented in this post Unable to get a new install of Supervised HA on Docker - #7 by mr-artizan hope this helps

There are now native libraries for handling the gpio pins on 64-bit Debian, have been available for at least a year or so (maybe longer), unfamiliar with 1WIRE

When I install everything new with Debian 12 when installing systemd-resolverd, everything breaks, the connection stops working and I have tried everything and I can’t get it to work

When we read this message, we don’t know, how you installed it, on what you installed it, what is that everything, you have tried, so we can’t get it to work too for you…

1 Like

He’s posting in a thread about installing Supervised on a Raspberry Pi :man_facepalming:

Read the whole thread and you will see, that this assumption has been made before and did not worked out :wink:

1 Like

installation on a 3B rpi, installation from 0 with debian 12, I try to install everything that it asks to install Ha supervi, everything is fine until I install systemd-resoult which stops working any internet connection and does not let me finish installing Ha, nor neither update nor ping google

In the end I got the ping to work, but since then it has been very slow and when I finish the HA installation it gives me an error
23-09-18 17:04:46 WARNING (MainThread) [supervisor.misc.tasks] Watchdog miss API response from Home Assistant
23-09-18 17:06:46 ERROR (MainThread) [supervisor.misc.tasks] Watchdog found a problem with Home Assistant API!
23-09-18 17:06:46 ERROR (MainThread) [supervisor.misc.tasks] Home Assistant watchdog reanimation failed!
23-09-18 17:08:46 WARNING (MainThread) [supervisor.misc.tasks] Watchdog miss API response from Home Assistant

right now ,it´s working, but very,very slow HA and console debian 12 TOO

Running on a Micro SD Card or an SSD (It’s like night and day)?

the rpi with sd card,but before install systemd-resoult the rpi went very fast,but after the install and change anything,the rpi and HA is very slowly,I change this:
nmcli con mod “501ba88f-a6be-4d68-bfd6-84696ba74aab” ipv4.dns “,”
domain localdomain
search localdomain.

Greetings all

I followed this guide (to the letter) for installation on an RPi 4 and also ran into the hostname resolution issue some have experienced (e.g. here ):

curl -fsSL | sh
curl: (6) Could not resolve host:

I could also not perform any other pings at this point.

Based on Allinijhof’s post which suggested that the issue might be with systemd-resolved, I proceeded to remove the package and try again.

This worked - I was once again able to ping successfully, resolve the docker and subsequent github links, and continue with the installtion.

I couldn’t complete the installation without systemd-resolved, however, as it is still required for the homeassistant-supervised package. But installing it (apt install systemd-resolved) just before running dpkg -i homeassistant-supervised.deb seemed to do the trick.

Now everything seems to be working and Home Assistant Observer reports that all is well.


If you’re struggling with address resolution issues, try swapping the order of systemd-resolved and homeassistant-supervised installation, i.e.:


sudo -i

apt update && sudo apt upgrade -y && sudo apt autoremove -y

apt --fix-broken install

apt install apparmor jq wget curl udisks2 libglib2.0-bin network-manager dbus lsb-release systemd-journal-remote -y  # (delete systemd-resolved)

curl -fsSL | sh


dpkg -i os-agent_1.6.0_linux_aarch64.deb


apt install systemd-resolved

dpkg -i homeassistant-supervised.deb

I tried again, and when installing systemd resolved, ping google doesn’t work or install, I changed
nmcli with mod “501ba88f-a6be-4d68-
bfd6- 84696ba74aab” ipv4.dns “,” and Google is already pinging, I have installed homeassistant supervisor, but it works very very slowly and crashes
and the homeassistant not start because
[supervisor.misc.tasks] Watchdog miss API response from Home Assistant

Where did you get “501ba88f-a6be-4d68-bfd6- 84696ba74aab” from?

Did you blindly copied/pasted some commands from this post without a clue what you are doing?

Really??? :crazy_face:

Do yourself (and this community) a favor and install Home Assistant OS on your Pi. There is nothing you will miss compared to the HA Supervised method which is considered advanced and should only be used if you are an expert in managing a Linux operating system, Docker and networking! Obviously you are not there yet.

1 Like

no,I put my nmcli with the mod, and not the one from crhis 1989, the problem with using the home assistant os is that I try to integrate a voltronic inverter and it doesn’t work, but with the ha docker I can install serial cable packages