Installing Home Assistant Supervised on a Raspberry Pi using Debian 12

HI, in the supervisor system i have this problem , how can i resolve?

20-12-02 16:30:34 ERROR (MainThread) [supervisor.store.git] Can't update https://github.com/sabeechen/hassio-google-drive-backup repo: Cmd('git') failed due to: exit code(128)
  cmdline: git fetch --depth=1 --update-shallow -v origin
  stderr: 'fatal: Unable to create '/data/addons/git/cebe7a76/.git/shallow.lock': File exists.
Another git process seems to be running in this repository, e.g.
an editor opened by 'git commit'. Please make sure all processes
are terminated then try again. If it still fails, a git process
may have crashed in this repository earlier:
remove the file manually to continue.'.type or paste code here

And one time at day , the home assistant installed in ssd with this tutorial, stops working and I have to reboot

I would suggest you visit the Github for this add-on, it is not to do with this guide.

At a guess your Pi3 is perhaps running out of memory. A Pi3 only has 1gb RAM, and sometimes the combination of HA and the OS will use more than this and cause a memory problem, which results in a system freeze.

Thanks for the great tutorial, worked like a charm!

I’m running it on a RPi 4 which sits in a case with a 4 inch touchscreen.

How would I get the display to show anything, now it says no signal.

I guess it has to do with the Debian image being used?

It may be a driver issue. I’m guessing you are using the DSI port?

No that display is plugged into the left HDMI port. When I plugged in the mini-HDMI cable into the other port on the right and hooked up a screen, it worked. However that’s not possible the way the touchscreen is build.

This is a very clear guide, thanks for the time and effort. The issue I have is with the HA install script - when it modifies (replaces?) the interfaces file (presumably to configure the docker interface), it breaks my wifi connectivity (which is in interfaces.d/wlan0 - I specify a static address, gateway, mask plus 2 nameservers) and leaves me without connectivity. Any clues what the issue is (including user error of course…)?

The simplest fix would be to install plugged into LAN, then once the install is complete, do your WiFi config. Using WiFi for HA is not recommended though.

Thanks for the reply. I’ll give it a go, although my preference is to use WiFi. I’ve been running the “all in one” HA Pi4 build on WiFi with no problems for a while - I do have a rock solid Unifi WiFi network. I just wanted more features (control?) in the underlying host hence trying this.

Hi @kanga_who / Jason,

Can I skip part 1.3 / 1.5 and go directly to SSH connection? I don’t have a spare monitor etc.
I tried open SHH, I have a connection to my Rpi but I don’t know the usernamen and password. Have surged Google and tried root/password but no luck.

Hi all,

i’ve the same problem, is there a way to get ssh work with the ssh empty file like the Raspberry Pi OS install ?

@Bastiaan1977

I found a solution for the headless install. you can activate the root login by editing the sysconfig.txt file and uncomment the root password and the root_authorized_key, than you should generate un public key to paste there.

1 Like

@kalemba
Thanks for your reply, I will try this first thing tomorrow

Hello kalemba. Can you explain me how do that?
I’ve uncomment root password and root_authorized_key, than I’ve not move root password and create a key with puttygen (selected SSH-1 RSA), copy and paste the code in root_authorized_key, save and put my card in Raspberry. When I try to access over ssh, I get a password error.
What I’m missing???

Hello @Mikypan81

Do you have some errors when you try to connect ?

If you are using putty to connect, after the key pair generated, you should configure the client to tell it where’s the private key, to do so, you should:

In putty configuration go to : Connexion > SSH > Auth and than browse to your file. after that if you try to connect with root that should work.

I’m sorry for my english i’m not a native speaker, tell me if you want me to detail the process more precisely.

finally succeeded! HA is running like a charm
thanks for all the work

Thanks for the guide! Quick question…I’m coming from Raspberry Pi OS after following your older tutorial many months ago. Suffered a very strange issue this morning where the homeassistant container appears to have deleted itself… Thought this was a sign to finally upgrade to something better/officially supported so I followed this tutorial. It worked very quickly and got to the landing page of a fresh install in ~10 min. After opting to restore a backed up image I had saved in the cloud, it restored everything successfully…except homeassistant itself. All of my former containers are listed with the notable exception of Homeassistant itself. As such, I can connect to zwave for example via the OpenZWave admin program for PC, but I cannot connect to the front end as this container doesn’t exist.

This is almost certaintly not an issue with this guide at all, but has anyone else encountered this issue? And if so, how did you resolve? I’ve left the restore running for over an hour hoping that this was just taking forever, but I’d have expected the restore to have completed by now…

EDIT: Nevermind I think I got it all back up and running now! I ended up restoring the snapshot again via hassio_cli. Second restore re-created the homeassistant container and I’m now on the front end :smiley:

1 Like

after rebooting the rPI HA is not starting. how can i solve this?

thanks,

I was going to suggest re-running the install script as that would pull the latest image again, but seems you got it sorted. :+1:

1 Like

What sort of Pi are you using? 3 or a 4?

Without any means to hitchhike your specific question/problem. But did you do an OS-update just before the reboot?

Running HA on a

  • Raspberry Pi 4, 4GB
  • SSD KINGSTON V400 120GB inside a
  • ORICO USB-C 3.1 Gen 2 HDD Enclosure 2159C3-G2

All used to work seamlessly and without any hiccups with this installation method.

Just as a report about some problems I ran into after routinely checking for system updates which I do once a week:

sudo apt update && sudo apt upgrade -y && sudo apt autoremove –y

After the update-process has finished Home Assistant quit working.

So I did a couple of OS-restarts but that did not help. Debian itself was booting without problems and SSH-access to the CLI worked. Just HA didn’t start.

So I decided to redo the whole process as per the instructions here which finished without errors. Nevertheless, the initial Logon/Restore from Snapshot-prompt took ages to load but finally did. All well I thought and after a complete Restore of the final snapshot and some fine-tuning I initiated another system reboot.

Which brought me back to: Debian itself was booting without problems and SSH-access to the CLI worked. But HA didn’t start…

So I stopped Docker, deleted all images and Volumes and finally removed Docker itself to redo all clean.

However, similar to the first attempt I was able to Logon into HA after an extended loading time but after a system reboot all went back to square 1: HA did not load to the end.

Unfortunately I missed to record the relevant log-entries to the latter but it has something to do with resolving names (HA’s internal DNS-server is not starting).

Today I have read an article reporting about some (breaking) changes to Docker which just received an update from version 19.03 to version 20.10. This update already found its way into the Debian 10 repos and was also installed with the latest system update.

Especially the changes to the settings for the hostname and the ports caught my attention since this is now done automatically by Docker. Additionally Docker 20.10 is now supporting cgroup v2 instead of cgroup v1 which is managing CPU-load, memory, storage and networking in a different way.

I suspect there are some incompatibilities between HA Supervised on Raspi Pi with Debian 10 and Docker 20.x which renders this installation method hard to use for the time being.

Unfortunately I am not very familiar with the Docker-world an therefore sadly I am unable to look into this by myself.