Installing Home Assistant Supervised on a Raspberry Pi using Debian 12

Interesting, thanks for the info. You should be able to install the correct version of Docker-ce by executing the following.

sudo apt install docker-ce=5:19.03.13~3-0~debian-buster

Let me know if that works.

OK, Just updated my test system and got the 20.x Docker update as you noted. Rebooted the machine after updating, HA did not auto-start, although I could manually start it using Portainer.

So, I did the following for testing purposes;

sudo apt remove docker-ce
sudo apt autoremove --purge -y
sudo reboot

When the Pi comes back online;

sudo apt install docker-ce=5:19.03.13~3-0~debian-buster
sudo apt-mark hold docker-ce docker-ce-cli containerd.io #thanks @jaalperin
sudo reboot

HA Came back up and running as normal.

5 Likes

Same problem as Tamsy. Been running supervised/Debian for months on two pi4 and one Lenovo m93p. Today I apt updated then upgraded to containerd.io/buster 1.4.3-1 from 1.3.9-1, docker-ce-cli/buster 5:20.10.0~3-0~debian-buster from 5:19.03.14~3-0~debian-buster, and docker-ce/buster 5:20.10.0~3-0~debian-buster from: 5:19.03.14~3-0~debian-buster. After rebooting the supervisor was unavailable and none of the addons were running. Thanks to TimesShift I was able to restore the older versions and get running again. So, I suggest folks stay with 5:19.03.14 and do not upgrade to 5:20 (sudo apt-mark hold docker-ce docker-ce-cli containerd.io).

3 Likes

Excellent, thanks for this.

2 Likes

That seems logical and should solve it. I am still at work now but will do the downgrade to Docker 19 and the following steps soon after an report back. Thank you for the solutions, kanga_who and jaalperin.

thanks for the fast replies…
Sorry about the few informations i have gave you…

I am on raspbian Buster 32 Bit.
therefore i used this during installation:

curl -sL “https://raw.githubusercontent.com/Kanga-Who/home-assistant/master/supervised-installer.sh” | bash -s – -m raspberrypi4

without the “-64”

downgrading the docker version resolved also my issue! thanks!!
on raspbian I had to use:
sudo apt install docker-ce=5:19.03.14~3-0~raspbian-buster

thanks to all

2 Likes

Thanks for the informative guide. I just wanted to get some help with the supervised installer script.

I have a Pi 4 and when I run the script, it stops after “Restarting Network Manager” with “Invalid Reference Format”

Do you know what could be going wrong?

Thanks in advance.

I’ve seen that somewhere else recently. Something to do with a network issue and the HA container not downloading correctly, can’t remember exactly. Try re-running Step 2.1 from the start again.

Started having issues once again after a couple hours due to the docker update. Retried one more time to re-install from scratch using these commands at the end and everything now works 100% successfully. Thanks!

Should be thanking this docker issue though, it forced me to redo my install and upgrade to a supported distro finally :joy:

1 Like

Thank you for this guide! It all went well for me except for minor issues (I needed to install sudo, wget, and unzip).

One problem came up, though. When the computer is rebooted, only the hassio_observer container automatically restarts. I can manually start the homeassistant and hassio-supervisor containers, and everything works. Did I miss a step?

Hello, for a fresh install of home assistant, this guide is ok???

Thank you so much. I thought my fresh HA installation was effed because I used the guide to install HA 64 bit on Raspberry Pi OS 64 bit.
In order to revive my installation I had to

sudo apt remove docker-ce docker-ce-cli
sudo apt autoremove --purge -y
sudo reboot

and now for the finale with a different minor version

sudo apt install docker-ce-cli=5:19.03.14~3-0~debian-buster
sudo apt install docker-ce=5:19.03.14~3-0~debian-buster
sudo apt-mark hold docker-ce docker-ce-cli containerd.io
sudo reboot

After restarting HA showed the installation screen followed by the login but asked me to grant permission for using the current installation by typing my login.
Is that expected?
In the end I was greeted by the expected page of my configured devices.

1 Like

This sounds like the docker issue that has come up in the last few days. I would try running the docker version and steps in this post: Installing Home Assistant Supervised on Debian 10

The steps are already linked in this thread, post 42. :wink:

Yep, that did the trick, thanks!

With the previous installation, hassio_observer was running after a reboot, but not homeassistant nor hassio_supervisor. I could manually start them, and it would continue working normally. So maybe a minor configuration adjustment is all that is needed.

Excuse me if I repost my question…but I don’t know how to act for a fresh install.
Please anyone can help me???
I’ve to follow this guide???
Or After curl -fsSL get.docker.com | sh I’ve do downgrade before install home assistant?

Thank you

You can do this. Will work fine.

Thank you so much kalemba! Now work perfectly!!! Thanks again!!!

Thanks for the script. As a heads up, on my version (Pi4/DietPi), I had to install docker-ce-cli=5:19.03.14~3-0~raspbian-buster instead of debian-buster. Seems to have worked!

Nice that you got it up and running by installing docker-ce-cli=5:19.03.14~3-0~raspbian-buster.

But you are in the wrong thread. This one is about installing HA Supervised on a Raspberry Pi with Debian 10 but not with Rasbian Buster…

1 Like