Installing Home Assistant Supervised on a Raspberry Pi using Debian 12

I don’t think so… once you get ssh running it’s headless from there but unless you had an image that sets it up with that headless then I’m not aware of any… or maybe a scripted install…

I didn’t.

I decided against this install due to not being able to use the fan or install a external HDD natively for my Plex movies (although there was a workaround with Samba). I’m instead using Raspberry PiOS and just installed HA via the container (not supervised).

nope you are wrong… I actually manage to install this remotely (headless) which you can follow on my guide at

1 Like

It seems that RaspberryPi OS 64bit works with this method and also gives access to the GPiO without issues.

Hi. Can somebody help me, that how can I update my Home Assistant Supervised CORE?
Supervisor : 2020.12.7
Core 2020.12.2 but there is an update in Supervisor Dashboard menu.> Home Assistant Core 2021.1.1.
!! My system get unofficial, bucause i have Wireguard and Mysql server too on my Pi 4!!

Are there any process for it, or i can just hit the UPDATE button?


I’m stuck … answered NO to the network manager question.

1 Like

you need to have sudo before curl to run the script

Follow the instructions.

I tried, no love :frowning: I did follow the instructions, in order…


That’s not what the instructions show you to do, read it again.

bash -s -- -m raspberrypi4

It seems to have worked. Many thanks Jason and David. Definitely looking forward to this!


Thanks for this great tutorial. Just one small thing:

sudo apt update && sudo apt upgrade -y && sudo apt autoremove –y

does something weird when copy pasting. the – is not a correct dash character
This will fix that for the copy paste people here:

sudo apt update && sudo apt upgrade -y && sudo apt autoremove -y

Is raspbian close enough to use? I’ve got an existing pi setup with other stuff, and it would be nice to not have to buy another. I get all the way through to the end and it seems that home assistant doesn’t start. The docker logs show this:

21-01-18 19:56:15 INFO (MainThread) [supervisor.homeassistant.core] Wait until Home Assistant is ready
21-01-18 19:56:20 ERROR (MainThread) [supervisor.homeassistant.core] Home Assistant has crashed!
21-01-18 19:56:20 ERROR (MainThread) [supervisor.homeassistant.core] Can't start Home Assistant!
21-01-18 19:56:20 INFO (SyncWorker_0) [supervisor.docker.interface] Cleanup images: ['homeassistant/raspberrypi4-64-homeassistant:landingpage']

Is this because I’m not on the official Debian 10? Is there some other logs I should check?

You can use Raspbian, but it is not a supported OS for HA.

Try running this line without the -64, follow the other instruction before this point also.

curl -sL "" | bash -s -- -m raspberrypi4

That worked for me, thanks.

Kind request: could you explain in layman terms why Debian is the officially supported OS for Home Assistant on a Raspberry Pi? Naively, I would have thought the Raspberry Pi OS to be the obvious choice; and I only say that for the trivial reason that it’s the OS specifically designed for that hardware.

Debian is the only supported OS for a Home Assistant Supervised installation. It doesn’t matter what machine you choose too use, Debian is the only supported OS.

1 Like

Yeah, but somehow HassOS is based on Alpine Linux. Go figure…

Hi need to update python in this debian 10? at python 3.9?
Work GPIO on PI4? I read the comments GPIO on Debian 10 does not work, is it true?

how you started GPIO doesn’t work for me