Installing Home Assistant Supervised on a Raspberry Pi using Debian 12

Yes. But it’s easier to stay on Docker 19 for the time being to be honest. Wait until the Beta Supervisor update gets rolled out as a version update.

I has been that for over a week now

1 Like


I am following this excellent guide, installing on a Raspberry Pi 3B. I have followed the steps as described, but the supervised install script stops after writing the NetworkManager configuration.

I am connected to the Pi with a serial usb module and I am using wpa_supplicant.conf to connect to Wifi for internet, which has been working OK until the script modifies the NetworkManager config.

Supervised install script output:

[info] Creating NetworkManager configuration
[warn] Changes are needed to the /etc/network/interfaces file
[info] If you have modified the network on the host manually, those can now be overwritten
[info] If you do not overwrite this now you need to manually adjust it later
[info] Do you want to proceed with that? [N/y]

[info] Restarting NetworkManager
[info] Install supervisor Docker container
[  256.794587] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
Error response from daemon: Get dial tcp: lookup on dial udp connect: network is unreachable
root@rpi3-20200831:~# [  257.390617] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  258.392582] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

No further response, and after that, the network becomes unreachable.

If I close the script and ping my router, I get

connect: Network is unreachable

iwconfig output:

lo        no wireless extensions.
eth0      no wireless extensions.
docker0   no wireless extensions.

wlan0     IEEE 802.11  ESSID:off/any
          Mode:Managed  Access Point: Not-Associated   Tx-Power=31 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

The router can see that an unknown device is trying to connect to it, but it is not receiving its MAC address and not assigning an IP.

My wlan0 interface config:

# /etc/network/interfaces.d/wlan0
auto wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
wireless-power off

If I reset the NetworkManager config files with

rm -rf /etc/NetworkManager/*
apt install --reinstall -o Dpkg::Options::="--force-confask,confnew,confmiss" network-manager

and reboot, then I get connected to Wifi again and can successfully ping google. I believe the issue is isolated in the NetworkManager config files.

Even if I make the following change:

# /etc/NetworkManager/system-connections/default
id=Supervisor default
type=802-11-wireless # <-----

and reboot, the same issue remains that network is unreachable. Not sure if this file defines the connection to the docker interface or to the internet, just letting you know what I tried.

Is the configuration that the script writes reliant on having an ethernet interface? How could I resolve this issue and continue with the install script? The intent is to have this device connected over Wifi, so I need to find a solution regardless of whether a wired ethernet workaround exists.

Files that are written to /etc/NetworkManager by the install script (for reference):

There is an issue with network manager randomizing the mac-address of wireless connections, so if you have a DHCP-reservation for your Wifi MAC it might fail.

Hi @kalemba firstly thanks for the hope of installing Debian without directly connected keyboard/monitor.
Will You be so kind to detail the procedure of tuening on SSH. I stuck with lack of sysconfig.txt. Should it be created? I am trying with debian-live-10.7.0-amd64-standard.iso on RPi4.

Im having a rpi4 and have done the tutorial, worked great!

However, I’m trying to setup a razberry z-wave device connected to the serials. I previously running on a Pi OS being able to use Raspi-config and adding a few lines to the config.txt. Aswell as adding the user of home assistant to the dialout group to enable serial.
However, I struggle to find the folder with config.tx for boot. Is it /boot/firmvare/config.txt?
Who is the user running hassio? Is is the one I created, and where is the home folder?

The config folder should be /usr/share/hassio/homeassistant

Great! Thank you.

And if I like home assistant to have access to the serials on the board. Since my z wave controller is attached to the pins.
What users should I include in the group dialout?
My device have the serial port:
rw-rw- - - root dialout dev/ttyS1

First of all, thanks for this amazing guide. Switched from unsupported environment in 15 minutes.

Now the RPI power add-on is not longer working, anyone knows a workaround for this?

PS: In the extra section to setup SMB share, there is a little fault in the guide. Before you do the sudo smbpasswd -a USERNAME_OF_YOUR_CHOICE command you first need to add the user to the system by using sudo adduser USERNAME_OF_YOUR_CHOICE, otherwise you get a error that it can not add a password for this user.

I believe the reason that RPI power is not available due to you are running Debian Buster instead of RaspiOS.

Well that’s strange. I’m running a official supported environment and the RPi addon is not working. I’m also running HASS on another RPi with Ubuntu 20.04 unsupported environment and there the addonn is working fine. :slight_smile:

I have updated:

Supervisor version 2020.12.7
Docker version 20.10.1

Everything works again :grin::grin:

To unlock docker I have used

sudo apt-mark unhold docker-ce docker-ce-cli

And next

sudo apt update -y && sudo apt upgrade -y
1 Like

Thanks for this.

I’m not sure what I’m doing wrong as the install seems to get to the last part but the container never seems to start. I start it and it stops almost immediately.

Did you find any answers?

I’m also having issues with needing to use the GPIO. Is the lack of support a known “official” issue?
Are there an useful threads on this that I can follow, with a view to trying to fix the issue?


It’s a known limitation.

There is a way but it involves using RaspiOS 64bit instead of Debian. I am running it fine for over a week and my system still shows up as supported

GPIO works fine for me but the built in Bluetooth stopped working but I found that this adapter works fine to restore BT.

Did you choose No for installing the Network manager? I guess you accidentally did not choose Yes and that’s why the container is not launching.

I did choose Yes and it happened. I removed and re-installed a number of times with the same outcome.

I finally saw @ibishop 's post and re-ran the install script using just “raspberrypi4” and it worked.

Is there away to install this debian without having a monitor or keyboard etc… I mean totally headless